aboutsummaryrefslogtreecommitdiffstats
path: root/cad/tochnog
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2004-05-06 02:27:53 +0800
committermaho <maho@FreeBSD.org>2004-05-06 02:27:53 +0800
commit160ef0a91bf4301d3d3da7ad0cd7e55905aba22e (patch)
treead6b78045f5feff2c8b8659bbe3d15abb222404d /cad/tochnog
parent2e024b0ec02c78a543d660626f6c8c12e4b81da3 (diff)
downloadfreebsd-ports-graphics-160ef0a91bf4301d3d3da7ad0cd7e55905aba22e.tar.gz
freebsd-ports-graphics-160ef0a91bf4301d3d3da7ad0cd7e55905aba22e.tar.zst
freebsd-ports-graphics-160ef0a91bf4301d3d3da7ad0cd7e55905aba22e.zip
Unbreak.
Suggestion by: "Pedro F. Giffuni" <giffunip@yahoo.com> and kris
Diffstat (limited to 'cad/tochnog')
-rw-r--r--cad/tochnog/Makefile2
-rw-r--r--cad/tochnog/files/patch-src+so_suplu.c22
2 files changed, 22 insertions, 2 deletions
diff --git a/cad/tochnog/Makefile b/cad/tochnog/Makefile
index f608b74262a..2fd45094fe3 100644
--- a/cad/tochnog/Makefile
+++ b/cad/tochnog/Makefile
@@ -23,8 +23,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu_mt.a:${PORTSDIR}/math/superlu_mt
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
.endif
-BROKEN= "Does not compile"
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
diff --git a/cad/tochnog/files/patch-src+so_suplu.c b/cad/tochnog/files/patch-src+so_suplu.c
new file mode 100644
index 00000000000..26c6e82a9eb
--- /dev/null
+++ b/cad/tochnog/files/patch-src+so_suplu.c
@@ -0,0 +1,22 @@
+--- so_suplu.c.orig Thu May 6 03:24:22 2004
++++ so_suplu.c Thu May 6 03:24:25 2004
+@@ -53,6 +53,8 @@
+ int *perm_r, *perm_c;
+ int perm_spec;
+ int nrhs;
++ SuperLUStat_t stat;
++ superlu_options_t options;
+ #endif
+
+ /* Create Matrix A in the format expected by SuperLU */
+@@ -103,7 +105,9 @@
+
+ /* Solve */
+ #if SUPERLU_USE
+- dgssv( &A, perm_c, perm_r, &L, &U, &B, &info );
++ /* Initialize the statistics variables. */
++ StatInit(&stat);
++ dgssv(&options, &A, perm_c, perm_r, &L, &U, &B, &stat, &info );
+ #elif SUPERLU_MT_USE
+ pdgssv( nthread, &A, perm_c, perm_r, &L, &U, &B, &info );
+ #elif SUPERLU_DIST_USE