aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-24 07:05:19 +0800
committeredwin <edwin@FreeBSD.org>2003-02-24 07:05:19 +0800
commit9b3ca8ca9c66a748a2964638ec2a59699c4a489b (patch)
tree081c8f7af75f134696484159d68ba548e11de8cb /cad
parent315c5d315b6b1efab8c7c79770ae4ac26140128a (diff)
downloadfreebsd-ports-graphics-9b3ca8ca9c66a748a2964638ec2a59699c4a489b.tar.gz
freebsd-ports-graphics-9b3ca8ca9c66a748a2964638ec2a59699c4a489b.tar.zst
freebsd-ports-graphics-9b3ca8ca9c66a748a2964638ec2a59699c4a489b.zip
Maintainer-update of cad/linux-eagle
The new install routine installs directories without user access bits set. PR: ports/48184 Submitted by: Thomas E. Zander <riggs@mugiri-in-au.dyndns.tv>
Diffstat (limited to 'cad')
-rw-r--r--cad/linux-eagle/Makefile3
-rw-r--r--cad/linux-eagle5/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/cad/linux-eagle/Makefile b/cad/linux-eagle/Makefile
index 84edc783f2b..c83d4cc4532 100644
--- a/cad/linux-eagle/Makefile
+++ b/cad/linux-eagle/Makefile
@@ -9,7 +9,7 @@ PORTNAME= linux-eagle
EAGLEVERSION?= 4.09r2
EAGLELANG?= e
PORTVERSION= ${EAGLEVERSION:S/r/./}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= cad linux
MASTER_SITES= ftp://ftp.cadsoft.de/pub/program/${EAGLEVERSION}/
DISTNAME= ${PORTNAME:S/linux-//}-${EAGLEVERSION}${EAGLELANG}
@@ -38,6 +38,7 @@ CPIO?= /usr/bin/cpio --quiet -pdum -R
do-install:
@${MKDIR} ${DATADIR}
@ cd ${WRKSRC} && ${FIND} * -type f -print | ${CPIO} ${BINOWN}:${BINGRP} ${DATADIR}
+ @ cd ${DATADIR} && ${FIND} * -type d -print | xargs ${CHMOD} 0755
@${LN} -sf ${DATADIR}/bin/eagle ${PREFIX}/bin/eagle
@${INSTALL_MAN} ${DATADIR}/man/eagle.1 ${PREFIX}/man/man1
diff --git a/cad/linux-eagle5/Makefile b/cad/linux-eagle5/Makefile
index 84edc783f2b..c83d4cc4532 100644
--- a/cad/linux-eagle5/Makefile
+++ b/cad/linux-eagle5/Makefile
@@ -9,7 +9,7 @@ PORTNAME= linux-eagle
EAGLEVERSION?= 4.09r2
EAGLELANG?= e
PORTVERSION= ${EAGLEVERSION:S/r/./}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= cad linux
MASTER_SITES= ftp://ftp.cadsoft.de/pub/program/${EAGLEVERSION}/
DISTNAME= ${PORTNAME:S/linux-//}-${EAGLEVERSION}${EAGLELANG}
@@ -38,6 +38,7 @@ CPIO?= /usr/bin/cpio --quiet -pdum -R
do-install:
@${MKDIR} ${DATADIR}
@ cd ${WRKSRC} && ${FIND} * -type f -print | ${CPIO} ${BINOWN}:${BINGRP} ${DATADIR}
+ @ cd ${DATADIR} && ${FIND} * -type d -print | xargs ${CHMOD} 0755
@${LN} -sf ${DATADIR}/bin/eagle ${PREFIX}/bin/eagle
@${INSTALL_MAN} ${DATADIR}/man/eagle.1 ${PREFIX}/man/man1