aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-21 07:36:35 +0800
committermarino <marino@FreeBSD.org>2014-08-21 07:36:35 +0800
commit46ae97cd515917b0efaa6277472e6529e6a6a861 (patch)
tree918520abd3c9062e65e33d4e50b1d41bbe79607d /chinese
parent3d7d84ae49339dfc09f5675378fc82b964e65856 (diff)
downloadfreebsd-ports-graphics-46ae97cd515917b0efaa6277472e6529e6a6a861.tar.gz
freebsd-ports-graphics-46ae97cd515917b0efaa6277472e6529e6a6a861.tar.zst
freebsd-ports-graphics-46ae97cd515917b0efaa6277472e6529e6a6a861.zip
Stage chinese/sunpinyin and unbreak on FreeBSD 10+
PR: 192844 Submitted by: Henry Hu
Diffstat (limited to 'chinese')
-rw-r--r--chinese/sunpinyin/Makefile5
-rw-r--r--chinese/sunpinyin/files/patch-src_portability.h10
2 files changed, 14 insertions, 1 deletions
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
index a04c2d4e042..32945e67f63 100644
--- a/chinese/sunpinyin/Makefile
+++ b/chinese/sunpinyin/Makefile
@@ -24,10 +24,13 @@ MAKE_ARGS+= --prefix=${PREFIX} --libdatadir=${PREFIX}/share
USE_LDCONFIG= yes
USES= scons gmake iconv pkgconfig tar:xz
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+INSTALL_TARGET= install --install-sandbox=${STAGEDIR}
-NO_STAGE= yes
post-patch:
@${CP} ${_DISTDIR}/lm_sc.t3g.arpa.tar.bz2 \
${_DISTDIR}/dict.utf8.tar.bz2 ${WRKSRC}/raw
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsunpinyin.so.3.0
+
.include <bsd.port.mk>
diff --git a/chinese/sunpinyin/files/patch-src_portability.h b/chinese/sunpinyin/files/patch-src_portability.h
new file mode 100644
index 00000000000..a352ab8de01
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-src_portability.h
@@ -0,0 +1,10 @@
+--- src/portability.h.orig 2014-08-19 21:12:42.000000000 -0400
++++ src/portability.h 2014-08-19 21:12:51.000000000 -0400
+@@ -42,6 +42,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <stdint.h>
++#include <stdlib.h>
+ #include <string>
+ #include <cstring>
+