aboutsummaryrefslogtreecommitdiffstats
path: root/comms/atslog
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-10 22:17:06 +0800
committerantoine <antoine@FreeBSD.org>2014-09-10 22:17:06 +0800
commita4c89220320e8e6d8dee7c11256078ef4ef09fe0 (patch)
tree829eb8a6e9bb9d5ca56e277533e8ff2993cc1aac /comms/atslog
parent25fc21ea81e79a1fdd9ae6af6d8893c01ea471f7 (diff)
downloadfreebsd-ports-graphics-a4c89220320e8e6d8dee7c11256078ef4ef09fe0.tar.gz
freebsd-ports-graphics-a4c89220320e8e6d8dee7c11256078ef4ef09fe0.tar.zst
freebsd-ports-graphics-a4c89220320e8e6d8dee7c11256078ef4ef09fe0.zip
- Allow staging as a regular user
- Shebangfix
Diffstat (limited to 'comms/atslog')
-rw-r--r--comms/atslog/Makefile7
-rw-r--r--comms/atslog/pkg-plist4
2 files changed, 8 insertions, 3 deletions
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index ec2e44de465..c432c55bb1b 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -3,7 +3,7 @@
PORTNAME= atslog
PORTVERSION= 2.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= comms
MASTER_SITES= BERLIOS
@@ -19,12 +19,14 @@ WWW_DESC= Install web interface
WWWGD_DESC= Graphic reports
GNU_CONFIGURE= yes
-USES= perl5
+USES= perl5 shebangfix
USE_RC_SUBR= ${PORTNAME}d
+SHEBANG_FILES= include/atslogcleardb.pl.in include/atslogdb.pl.in
PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL LICENSE TODO UPDATING USAGE
SUB_FILES= pkg-message
CONFIGS= ${PORTNAME}.conf.default ${PORTNAME}.conf.default.rus
CONFIGURE_ARGS+=--localstatedir=/var
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
OPTIONS_SUB=yes
.include <bsd.port.options.mk>
@@ -102,7 +104,6 @@ do-install:
${FIND} -E . -type f ! -iregex "(.*Makefile|.*\.orig)" -exec \
${INSTALL_DATA} "{}" "${STAGEDIR}${WWWDIR}/{}" \;
${MV} ${STAGEDIR}${WWWDIR}/include/config.inc.php.default ${STAGEDIR}${WWWDIR}/include/config.inc.php.sample
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
diff --git a/comms/atslog/pkg-plist b/comms/atslog/pkg-plist
index 9c361d326ff..b3742a9a2b5 100644
--- a/comms/atslog/pkg-plist
+++ b/comms/atslog/pkg-plist
@@ -103,6 +103,8 @@ man/ru.KOI8-R/man8/atslogmaster.8.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textlogs/Siemens Hicom-250.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textlogs/Siemens Hicom-350H.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textlogs/Telrad.txt
+%%WWW%%@owner %%WWWOWN%%
+%%WWW%%@group %%WWWGRP%%
%%WWW%%%%WWWDIR%%/phonebook/index.html
%%WWW%%%%WWWDIR%%/phonebook/index.php
%%WWW%%%%WWWDIR%%/intern/index.html
@@ -333,6 +335,8 @@ man/ru.KOI8-R/man8/atslogmaster.8.gz
%%WWW%%@dirrmtry %%WWWDIR%%/calls/query
%%WWW%%@dirrmtry %%WWWDIR%%/calls
%%WWW%%@dirrmtry %%WWWDIR%%
+%%WWW%%@owner root
+%%WWW%%@group wheel
@dirrmtry libexec/atslog
@dirrmtry %%DATADIR%%/lang
@dirrmtry %%DATADIR%%/sql