aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gammu/files
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2007-08-21 04:51:50 +0800
committerbsam <bsam@FreeBSD.org>2007-08-21 04:51:50 +0800
commit20f67e72292ac0b2e055e41a3f0776fd15905583 (patch)
treef8101e4e06b13fb561da311f4537eb3a12bc9867 /comms/gammu/files
parent50727ca8956c06eb522073a4ef7ac062fcde34e2 (diff)
downloadfreebsd-ports-graphics-20f67e72292ac0b2e055e41a3f0776fd15905583.tar.gz
freebsd-ports-graphics-20f67e72292ac0b2e055e41a3f0776fd15905583.tar.zst
freebsd-ports-graphics-20f67e72292ac0b2e055e41a3f0776fd15905583.zip
. update to stable release 1.13.0;
. remove patch patch-common-CMakeLists.txt (incorporated upstream).
Diffstat (limited to 'comms/gammu/files')
-rw-r--r--comms/gammu/files/patch-CMakeLists.txt16
-rw-r--r--comms/gammu/files/patch-common-CMakeLists.txt17
2 files changed, 8 insertions, 25 deletions
diff --git a/comms/gammu/files/patch-CMakeLists.txt b/comms/gammu/files/patch-CMakeLists.txt
index a723b9e5c03..bf9452a684c 100644
--- a/comms/gammu/files/patch-CMakeLists.txt
+++ b/comms/gammu/files/patch-CMakeLists.txt
@@ -1,19 +1,19 @@
---- CMakeLists.txt.orig 2007-06-12 14:30:30.000000000 +0400
-+++ CMakeLists.txt 2007-08-10 04:20:32.000000000 +0400
-@@ -627,7 +627,7 @@
- set (INSTALL_DOC_DIR "share/doc/gammu" CACHE FILEPATH "Path for documentation installation")
+--- CMakeLists.txt.orig 2007-08-08 16:30:55.000000000 +0400
++++ CMakeLists.txt 2007-08-21 00:18:05.000000000 +0400
+@@ -601,7 +604,7 @@
+ set (INSTALL_DOC_DIR "share/doc/gammu" CACHE STRING "Path for documentation installation")
mark_as_advanced (INSTALL_DOC_DIR)
--set (INSTALL_MAN_DIR "share/man" CACHE FILEPATH "Path for man pages installation")
-+set (INSTALL_MAN_DIR "man" CACHE FILEPATH "Path for man pages installation")
+-set (INSTALL_MAN_DIR "share/man" CACHE STRING "Path for man pages installation")
++set (INSTALL_MAN_DIR "man" CACHE STRING "Path for man pages installation")
mark_as_advanced (INSTALL_MAN_DIR)
# Generate pkgconfig file
-@@ -688,7 +688,7 @@
+@@ -662,7 +665,7 @@
install (
FILES "${Gammu_BINARY_DIR}/cfg/gammu.pc"
-- DESTINATION "lib/pkgconfig"
+- DESTINATION "${INSTALL_LIB_DIR}/pkgconfig"
+ DESTINATION "libdata/pkgconfig"
COMPONENT "development"
)
diff --git a/comms/gammu/files/patch-common-CMakeLists.txt b/comms/gammu/files/patch-common-CMakeLists.txt
deleted file mode 100644
index 748e62ef15e..00000000000
--- a/comms/gammu/files/patch-common-CMakeLists.txt
+++ /dev/null
@@ -1,17 +0,0 @@
---- common/CMakeLists.txt.orig 2007-06-07 19:16:17.000000000 +0400
-+++ common/CMakeLists.txt 2007-08-06 01:35:01.000000000 +0400
-@@ -102,6 +102,14 @@
- endif (NOT "${BLUEZ_LIBRARIES}" STREQUAL "")
- endif (BLUEZ_FOUND)
-
-+if (ICONV_FOUND)
-+ target_link_libraries (Gammu ${ICONV_LIBRARIES})
-+ include_directories (${ICONV_INCLUDE_DIR})
-+ if (NOT "${ICONV_LIBRARIES}" STREQUAL "")
-+ set (GAMMU_LIBS "${GAMMU_LIBS} -l${ICONV_LIBRARIES}")
-+ endif (NOT "${ICONV_LIBRARIES}" STREQUAL "")
-+endif (ICONV_FOUND)
-+
- if (NOT HAVE_SIN)
- target_link_libraries (Gammu m)
- endif (NOT HAVE_SIN)