aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-12-17 18:39:33 +0800
committerdinoex <dinoex@FreeBSD.org>2013-12-17 18:39:33 +0800
commit32edd8974dcea555e64610cd95cd315f4f189745 (patch)
treefd617152549e8a260e6ddd369d5e1d6014f38a57 /comms/hylafax
parent0f4caa73a2b8207180a31ccb3f98331c6c351d88 (diff)
downloadfreebsd-ports-graphics-32edd8974dcea555e64610cd95cd315f4f189745.tar.gz
freebsd-ports-graphics-32edd8974dcea555e64610cd95cd315f4f189745.tar.zst
freebsd-ports-graphics-32edd8974dcea555e64610cd95cd315f4f189745.zip
- use STAGEDIR
- use OPTIONS_SUB - use OPT_* - remove obsolete pre-extract
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile85
-rw-r--r--comms/hylafax/pkg-plist94
2 files changed, 102 insertions, 77 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 22341893e64..3bc7cf8f583 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -15,7 +15,8 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libjbig.so:${PORTSDIR}/graphics/jbigkit
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
+#NO_STAGE= yes
+NEED_ROOT= yes
USE_GHOSTSCRIPT=yes
HAS_CONFIGURE= yes
@@ -29,36 +30,32 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-DIR_HTML="${DOCSDIR}"
CFLAGS+= -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -Wall -L${LOCALBASE}/lib
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
+MAKE_ENV+= ROOT=${STAGEDIR}
MAKE_ARGS+= OPTIMIZER="" -DOPTIMIZER
PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
SUB_FILES= pkg-message
USE_RC_SUBR= hylafax
-MAN1= edit-faxcover.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 \
- hylafax-client.1 sendfax.1 sendpage.1 sgi2fax.1 textfmt.1
-
-MAN5= dialrules.5f doneq.5f hosts.hfaxd.5f \
- hylafax-config.5f hylafax-info.5f hylafax-log.5f hylafax-server.5f \
- hylafax-shutdown.5f pagermap.5f pagesizes.5f recvq.5f sendq.5f \
- status.5f tsi.5f typerules.5f xferfaxlog.5f
-
-MAN8= choptest.8c cqtest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
- faxadduser.8c faxanswer.8c faxconfig.8c faxcron.8c faxdeluser.8c \
- faxgetty.8c faxinfo.8c faxlock.8c faxmodem.8c faxq.8c \
- faxqclean.8c faxquit.8c faxrcvd.8c faxsend.8c faxsetup.8c faxstate.8c \
- faxwatch.8c hfaxd.8c jobcontrol.8c mkcover.8c notify.8c pagesend.8c pdf2fax.8c \
- pollrcvd.8c ps2fax.8c recvstats.8c tagtest.8c tiff2fax.8c \
- tiffcheck.8c tsitest.8c wedged.8c xferfaxstats.8c
-
-SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
- ${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
+SUID_EXES= ${STAGEDIR}${PREFIX}/sbin/faxgetty \
+ ${STAGEDIR}${PREFIX}/sbin/faxq \
+ ${STAGEDIR}${PREFIX}/bin/faxrm \
+ ${STAGEDIR}${PREFIX}/bin/faxalter
OPTIONS_DEFINE= PAM NLS GAWK DOCS
OPTIONS_DEFAULT=PAM NLS
NO_OPTIONS_SORT=yes
+OPTIONS_SUB= yes
GAWK_DESC= Use gawk for scripts
+PAM_CONFIGURE_OFF= --disable-pam
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+GAWK_BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+GAWK_RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+GAWK_CONFIGURE_ON= --with-AWK="${LOCALBASE}/bin/gawk"
+DOCS_CONFIGURE_ON= --with-HTML=yes
+
.include <bsd.port.options.mk>
# Defaults to "North American Letter". Use "ISO A4" for A4.
@@ -66,19 +63,6 @@ GAWK_DESC= Use gawk for scripts
CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
-# Want PAM?
-.if empty(PORT_OPTIONS:MPAM)
-CONFIGURE_ARGS+=--disable-pam
-.endif
-
-# Want HTML documentation?
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+=--with-HTML=yes
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
# Redefine path for spool
.if defined(HYLAFAX_SPOOL)
CONFIGURE_ARGS+=--with-DIR_SPOOL="${HYLAFAX_SPOOL}"
@@ -90,28 +74,10 @@ PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
CONFIGURE_ARGS+=--nointeractive
.endif
-.if ${PORT_OPTIONS:MGAWK}
-BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
-RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
-CONFIGURE_ARGS+=--with-AWK="${LOCALBASE}/bin/gawk"
-.endif
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= WITH_NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= WITH_NLS="@comment "
+.if ${OSVERSION} >= 900007
+CONFIGURE_ARGS+= --with-GETTY=SysV
.endif
-pre-extract:
- @if [ -d /var/db/pkg/tiff-3.6.1 ]; then \
- ${ECHO_MSG} ""; \
- ${ECHO_MSG} "Hylafax does not work with libtiff-3.6.1."; \
- ${ECHO_MSG} "Please upgrade to libtiff-3.6.1_1. (/usr/ports/graphics/tiff)"; \
- ${ECHO_MSG} ""; \
- exit 1; \
- fi
-
post-patch:
${REINPLACE_CMD} \
-e 's,/usr/local,${LOCALBASE},g' \
@@ -123,20 +89,15 @@ post-patch:
-e 's,-O pagesizes,-O pagesizes-dist -src pagesizes,' \
${WRKSRC}/libhylafax/Makefile.in
+pre-install:
+ ${MKDIR} ${STAGEDIR}${HYLAFAX_SPOOL}
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
-.for f in hfaxd.conf pagesizes typerules
- if [ ! -f ${PREFIX}/lib/fax/${f} ]; then ${CP} -p ${PREFIX}/lib/fax/${f}-dist ${PREFIX}/lib/fax/${f}; fi
-.endfor
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.if ${OSVERSION} >= 900007
-CONFIGURE_ARGS+= --with-GETTY=SysV
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/comms/hylafax/pkg-plist b/comms/hylafax/pkg-plist
index 202ee0d8aa3..5effa4f209c 100644
--- a/comms/hylafax/pkg-plist
+++ b/comms/hylafax/pkg-plist
@@ -18,6 +18,70 @@ lib/fax/pagesizes-dist
lib/fax/typerules-dist
@exec [ -f %B/typerules ] || cp %B/%f %B/typerules
@dirrm lib/fax
+man/man1/edit-faxcover.1.gz
+man/man1/faxalter.1.gz
+man/man1/faxcover.1.gz
+man/man1/faxmail.1.gz
+man/man1/faxrm.1.gz
+man/man1/faxstat.1.gz
+man/man1/hylafax-client.1.gz
+man/man1/sendfax.1.gz
+man/man1/sendpage.1.gz
+man/man1/sgi2fax.1.gz
+man/man1/textfmt.1.gz
+man/man5/dialrules.5f.gz
+man/man5/doneq.5f.gz
+man/man5/hosts.hfaxd.5f.gz
+man/man5/hylafax-config.5f.gz
+man/man5/hylafax-info.5f.gz
+man/man5/hylafax-log.5f.gz
+man/man5/hylafax-server.5f.gz
+man/man5/hylafax-shutdown.5f.gz
+man/man5/pagermap.5f.gz
+man/man5/pagesizes.5f.gz
+man/man5/recvq.5f.gz
+man/man5/sendq.5f.gz
+man/man5/status.5f.gz
+man/man5/tsi.5f.gz
+man/man5/typerules.5f.gz
+man/man5/xferfaxlog.5f.gz
+man/man8/choptest.8c.gz
+man/man8/cqtest.8c.gz
+man/man8/dialtest.8c.gz
+man/man8/faxabort.8c.gz
+man/man8/faxaddmodem.8c.gz
+man/man8/faxadduser.8c.gz
+man/man8/faxanswer.8c.gz
+man/man8/faxconfig.8c.gz
+man/man8/faxcron.8c.gz
+man/man8/faxdeluser.8c.gz
+man/man8/faxgetty.8c.gz
+man/man8/faxinfo.8c.gz
+man/man8/faxlock.8c.gz
+man/man8/faxmodem.8c.gz
+man/man8/faxq.8c.gz
+man/man8/faxqclean.8c.gz
+man/man8/faxquit.8c.gz
+man/man8/faxrcvd.8c.gz
+man/man8/faxsend.8c.gz
+man/man8/faxsetup.8c.gz
+man/man8/faxstate.8c.gz
+man/man8/faxwatch.8c.gz
+man/man8/hfaxd.8c.gz
+man/man8/jobcontrol.8c.gz
+man/man8/mkcover.8c.gz
+man/man8/notify.8c.gz
+man/man8/pagesend.8c.gz
+man/man8/pdf2fax.8c.gz
+man/man8/pollrcvd.8c.gz
+man/man8/ps2fax.8c.gz
+man/man8/recvstats.8c.gz
+man/man8/tagtest.8c.gz
+man/man8/tiff2fax.8c.gz
+man/man8/tiffcheck.8c.gz
+man/man8/tsitest.8c.gz
+man/man8/wedged.8c.gz
+man/man8/xferfaxstats.8c.gz
sbin/textfmt
sbin/faxmsg
sbin/faxadduser
@@ -57,21 +121,21 @@ sbin/probemodem
sbin/lockname
sbin/ondelay
sbin/hylafax
-%%WITH_NLS%%share/locale/de/LC_MESSAGES/hylafax-client.mo
-%%WITH_NLS%%share/locale/de/LC_MESSAGES/hylafax-server.mo
-%%WITH_NLS%%share/locale/de/LC_MESSAGES/libhylafax.mo
-%%WITH_NLS%%share/locale/es/LC_MESSAGES/hylafax-client.mo
-%%WITH_NLS%%share/locale/es/LC_MESSAGES/hylafax-server.mo
-%%WITH_NLS%%share/locale/es/LC_MESSAGES/libhylafax.mo
-%%WITH_NLS%%share/locale/id/LC_MESSAGES/hylafax-client.mo
-%%WITH_NLS%%share/locale/id/LC_MESSAGES/hylafax-server.mo
-%%WITH_NLS%%share/locale/id/LC_MESSAGES/libhylafax.mo
-%%WITH_NLS%%share/locale/nl/LC_MESSAGES/hylafax-client.mo
-%%WITH_NLS%%share/locale/nl/LC_MESSAGES/hylafax-server.mo
-%%WITH_NLS%%share/locale/nl/LC_MESSAGES/libhylafax.mo
-%%WITH_NLS%%share/locale/vi/LC_MESSAGES/hylafax-client.mo
-%%WITH_NLS%%share/locale/vi/LC_MESSAGES/hylafax-server.mo
-%%WITH_NLS%%share/locale/vi/LC_MESSAGES/libhylafax.mo
+%%NLS%%share/locale/de/LC_MESSAGES/hylafax-client.mo
+%%NLS%%share/locale/de/LC_MESSAGES/hylafax-server.mo
+%%NLS%%share/locale/de/LC_MESSAGES/libhylafax.mo
+%%NLS%%share/locale/es/LC_MESSAGES/hylafax-client.mo
+%%NLS%%share/locale/es/LC_MESSAGES/hylafax-server.mo
+%%NLS%%share/locale/es/LC_MESSAGES/libhylafax.mo
+%%NLS%%share/locale/id/LC_MESSAGES/hylafax-client.mo
+%%NLS%%share/locale/id/LC_MESSAGES/hylafax-server.mo
+%%NLS%%share/locale/id/LC_MESSAGES/libhylafax.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/hylafax-client.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/hylafax-server.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/libhylafax.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/hylafax-client.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/hylafax-server.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/libhylafax.mo
@cwd %%HYLAFAX_SPOOL%%
COPYRIGHT
@exec mkfifo %D/FIFO