aboutsummaryrefslogtreecommitdiffstats
path: root/comms/xastir
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-25 13:24:30 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-25 13:24:30 +0800
commit62c5bdcc836220026f8c14dee68e1722fa6b812e (patch)
treecc69b6c3e52ff3ff54251ec2df3b3c5531182943 /comms/xastir
parent5388d32705e8bfdae365739eb2f70775ad9c650c (diff)
downloadfreebsd-ports-graphics-62c5bdcc836220026f8c14dee68e1722fa6b812e.tar.gz
freebsd-ports-graphics-62c5bdcc836220026f8c14dee68e1722fa6b812e.tar.zst
freebsd-ports-graphics-62c5bdcc836220026f8c14dee68e1722fa6b812e.zip
- Update to 1.5.0 [1]
- Use SUB_FILES=pkg-message PR: ports/81376 [1] Submitted by: maintainer [1]
Diffstat (limited to 'comms/xastir')
-rw-r--r--comms/xastir/Makefile40
-rw-r--r--comms/xastir/distinfo4
-rw-r--r--comms/xastir/files/pkg-message.in (renamed from comms/xastir/pkg-message)0
-rw-r--r--comms/xastir/pkg-plist23
4 files changed, 50 insertions, 17 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 8e65a8074f8..7b229fab3ef 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xastir
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.0
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xastir
@@ -22,20 +22,27 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_MOTIF= yes
+USE_GETTEXT= yes
USE_REINPLACE= yes
MAN1= xastir.1
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
OPTIONS= SHAPELIB "Include Shapelib support" On \
- PCRE "Include Perl Compatible Regular Expression Support" On \
+ PCRE "Include Perl Compat Regular Expression Support" On \
DBFAWK "Include DBFAWK Support" On \
MAGICK "Include ImageMagick Support" On \
CURL "Include CURL Internet Image support" On \
GDAL "Include GDAL Support" Off \
GPSMAN "Include GPSMAN Support" Off \
FESTIVAL "Include Festival Voice Synthesis Support" Off \
+ RTREE "Enable spatial indexing of shapefiles" Off \
+ ERRORPOP "Send error popups to stderr" Off \
+ DB40 "Tiger Map Caching using Berkeley DB v4.0" Off \
+ DB41 "Tiger Map Caching using Berkeley DB v4.1" Off \
+ DB42 "Tiger Map Caching using Berkeley DB v4.2" Off \
+ DB43 "Tiger Map Caching using Berkeley DB v4.3" Off \
OPTCFLAGS "Use optimized CFLAGS (-O2 -pipe)" Off
.include <bsd.port.pre.mk>
@@ -88,6 +95,30 @@ LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
CONFIGURE_ARGS+= --without-gdal
.endif
+.if defined(WITH_RTREE)
+CONFIGURE_ARGS+= --with-rtree
+.endif
+
+.if defined(WITH_ERRORPOP)
+CONFIGURE_ARGS+= --with-errorpopups
+.endif
+
+.if defined(WITH_DB40)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db4
+.endif
+
+.if defined(WITH_DB41)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db41
+.endif
+
+.if defined(WITH_DB42)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db42
+.endif
+
+.if defined(WITH_DB43)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db43
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
WITH_OPTCFLAGS= true
.endif
@@ -99,9 +130,8 @@ CFLAGS+= -O2 -pipe
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/comms/xastir/distinfo b/comms/xastir/distinfo
index 083efe21ad6..7109ac40361 100644
--- a/comms/xastir/distinfo
+++ b/comms/xastir/distinfo
@@ -1,2 +1,2 @@
-MD5 (xastir-1.4.1.tar.gz) = 55a7e8382b672f7454fc260f750af074
-SIZE (xastir-1.4.1.tar.gz) = 1391017
+MD5 (xastir-1.5.0.tar.gz) = 665e252af05f16ba0ba1b6fc2ed40c6d
+SIZE (xastir-1.5.0.tar.gz) = 1466883
diff --git a/comms/xastir/pkg-message b/comms/xastir/files/pkg-message.in
index d5708a3acfc..d5708a3acfc 100644
--- a/comms/xastir/pkg-message
+++ b/comms/xastir/files/pkg-message.in
diff --git a/comms/xastir/pkg-plist b/comms/xastir/pkg-plist
index 4020e7d114c..4d2dfdf54e6 100644
--- a/comms/xastir/pkg-plist
+++ b/comms/xastir/pkg-plist
@@ -4,6 +4,7 @@ lib/xastir/Coordinate.pm
lib/xastir/Xastir_tigerpoly.py
lib/xastir/coord-convert.pl
lib/xastir/fcc-get
+lib/xastir/get-gnis
lib/xastir/icontable.pl
lib/xastir/inf2geo.pl
lib/xastir/kiss-off.pl
@@ -24,6 +25,7 @@ lib/xastir/xastir-fixcfg.sh
lib/xastir/xastir-migrate.sh
share/xastir/Counties/placeholder
share/xastir/GNIS/placeholder
+share/xastir/config/24kgrid.dbfawk
share/xastir/config/gps_wpt.dbfawk
share/xastir/config/language-Dutch.sys
share/xastir/config/language-English.sys
@@ -71,6 +73,7 @@ share/xastir/doc/INSTALL
share/xastir/doc/LICENSE
share/xastir/doc/README
share/xastir/doc/README.CVS
+share/xastir/doc/README.Contributing
share/xastir/doc/README.Getting-Started
share/xastir/doc/README.MAPS
share/xastir/doc/README.win32
@@ -104,16 +107,16 @@ share/xastir/symbols/tornado.xbm
share/xastir/symbols/wind.xbm
share/xastir/symbols/winter_wx.xbm
share/xastir/symbols/wntr_strm.xbm
-@dirrm share/xastir/Counties
-@dirrm share/xastir/GNIS
-@dirrm share/xastir/config
-@dirrm share/xastir/doc
-@dirrm share/xastir/fcc
-@dirrm share/xastir/help
-@dirrm share/xastir/maps/GPS
+@dirrm share/xastir/symbols
+@dirrm share/xastir/sounds
@dirrm share/xastir/maps/Online
+@dirrm share/xastir/maps/GPS
@dirrm share/xastir/maps
-@dirrm share/xastir/sounds
-@dirrm share/xastir/symbols
-@dirrm lib/xastir
+@dirrm share/xastir/help
+@dirrm share/xastir/fcc
+@dirrm share/xastir/doc
+@dirrm share/xastir/config
+@dirrm share/xastir/GNIS
+@dirrm share/xastir/Counties
@dirrm share/xastir
+@dirrm lib/xastir