aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-13 23:02:06 +0800
committermiwi <miwi@FreeBSD.org>2009-08-13 23:02:06 +0800
commit12db5f97b31729f7bd574c91c3474877f46cab5e (patch)
tree905169741c4240233a7be0e4272d7925da26bcb4 /comms
parentac851832067586270385a05d7756a6ba83f50a1b (diff)
downloadfreebsd-ports-graphics-12db5f97b31729f7bd574c91c3474877f46cab5e.tar.gz
freebsd-ports-graphics-12db5f97b31729f7bd574c91c3474877f46cab5e.tar.zst
freebsd-ports-graphics-12db5f97b31729f7bd574c91c3474877f46cab5e.zip
An Amateur Radio callsign lookup command, made in Ruby,
to look up US Amateur Radio Operators. WWW: http://rubyforge.org/projects/callsign/ PR: ports/137548 Submitted by: Rick Elrod <codeblock at eighthbit.net>
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/callsign/Makefile26
-rw-r--r--comms/callsign/distinfo3
-rw-r--r--comms/callsign/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 2e1733f905f..c87467bf814 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -16,6 +16,7 @@
SUBDIR += bluegps
SUBDIR += bluez-firmware
SUBDIR += bpl+
+ SUBDIR += callsign
SUBDIR += cdr_read
SUBDIR += chu
SUBDIR += comserv
diff --git a/comms/callsign/Makefile b/comms/callsign/Makefile
new file mode 100644
index 00000000000..e66a5fc4d27
--- /dev/null
+++ b/comms/callsign/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: callsign-bin
+# Date created: 31 July 2009
+# Whom: Rick Elrod <codeblock@eighthbit.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= callsign
+PORTVERSION= 1.0.1
+CATEGORIES= comms net
+MASTER_SITES= RF
+DISTNAME= callsign-${PORTVERSION}
+
+MAINTAINER= codeblock@eighthbit.net
+COMMENT= An amateur radio callsign lookup command
+
+RUN_DEPENDS= rubygem-callsign>=0:${PORTSDIR}/comms/rubygem-callsign
+
+WRKSRC= ${WRKDIR}
+NO_BUILD= YES
+PLIST_FILES= bin/callsign
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/callsign ${LOCALBASE}/bin/
+
+.include <bsd.port.mk>
diff --git a/comms/callsign/distinfo b/comms/callsign/distinfo
new file mode 100644
index 00000000000..da493142370
--- /dev/null
+++ b/comms/callsign/distinfo
@@ -0,0 +1,3 @@
+MD5 (callsign-1.0.1.tar.gz) = 4abb6cddab69db80a0ca2d6447b85c63
+SHA256 (callsign-1.0.1.tar.gz) = e67070c918febacb4aa720063cacec79a8cf2f6da3c92b7f4e840100af2796ae
+SIZE (callsign-1.0.1.tar.gz) = 1289
diff --git a/comms/callsign/pkg-descr b/comms/callsign/pkg-descr
new file mode 100644
index 00000000000..3179664eda1
--- /dev/null
+++ b/comms/callsign/pkg-descr
@@ -0,0 +1,5 @@
+An Amateur Radio callsign lookup command, made in Ruby,
+to look up US Amateur Radio Operators.
+
+WWW: http://rubyforge.org/projects/callsign/
+