aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
committerhrs <hrs@FreeBSD.org>2015-08-23 01:48:35 +0800
commit52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2 (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /comms
parent069a5644197c0b8b71f45d29221cd5192af4c720 (diff)
downloadfreebsd-ports-graphics-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.gz
freebsd-ports-graphics-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.tar.zst
freebsd-ports-graphics-52f2507f3ec0cb2b7b96aa2ba867c924e7b8c9a2.zip
- Split ghostscript into X11-independent and -dependent parts:
* print/ghostscript{7,8,9,9-agpl}-base Installs Ghostscript binary, libgs, and related files. These ports do not depend on X11 libraries (i.e. x11* devices are not available). USES=ghostscript will set dependency on one of them depending on GHOSTSCRIPT_DEFAULT. The default device is set to "display" or "bbox". * print/ghostscript{7,8,9,9-agpl}-x11 Installs a shared library which provides X11 support to the installed Ghostscript binaries. x11* devices will be enabled when the library is available. This depends on *-base (RUN_DEPENDS). USES=ghostscript:x11 will set dependency on one of them. - Fix integer overflow reported as CVE-2015-3228. - Update Uses/ghostscript.mk: * Add x11 keyword. nox11 keyword is now obsolete. * Use packagename in *_DEPENDS line to prevent relationship between -base and -x11 packages from being broken. - Fix x11/nox11 keyword and bump PORTREVISION in ports using USES=ghostscript to update dependency of pre-compiled packages.
Diffstat (limited to 'comms')
-rw-r--r--comms/efax-gtk/Makefile2
-rw-r--r--comms/hylafax/Makefile2
-rw-r--r--comms/tkhylafax/Makefile4
3 files changed, 4 insertions, 4 deletions
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index 0caeb75202b..d1ea2b0b594 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= efax-gtk
PORTVERSION= 3.2.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms
MASTER_SITES= SF
EXTRACT_SUFX= .src.tgz
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 7bd1fff4bf9..2b5b5b8c49b 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hylafax
PORTVERSION= 6.0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
diff --git a/comms/tkhylafax/Makefile b/comms/tkhylafax/Makefile
index b83ad4c82f4..4c764ad05eb 100644
--- a/comms/tkhylafax/Makefile
+++ b/comms/tkhylafax/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tkhylafax
PORTVERSION= 3.2b
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= comms tk
MASTER_SITES= ftp://ftp.hylafax.org/contrib/tkhylafax/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
@@ -14,7 +14,7 @@ COMMENT= Tcl/tk interface to Sam Leffler's fax package
RUN_DEPENDS= sendfax:${PORTSDIR}/comms/hylafax \
gv:${PORTSDIR}/print/gv
-USES+= ghostscript:run tk:run
+USES= tk:run
WRKSRC= ${WRKDIR}/tkhylafax
MAKE_ARGS= STAGEDIR=${STAGEDIR} PREFIX=${STAGEDIR}${PREFIX} TCLSH=${TCLSH} WISH=${WISH}