aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /comms
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-graphics-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-graphics-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-graphics-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'comms')
-rw-r--r--comms/dabstick-radio/Makefile2
-rw-r--r--comms/efax-gtk/Makefile2
-rw-r--r--comms/ems-flasher/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index 8e32e0ae7b5..6348c9e0b77 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -40,7 +40,7 @@ CC= clang
CXX= clang++
CPP= clang-cpp
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
do-configure:
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index cd1bb47a4c7..00a6d13338e 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -20,7 +20,7 @@ USES= pkgconfig
USE_GHOSTSCRIPT_RUN=yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-USE_GCC= 4.4+
+USE_GCC= yes
CONFLICTS= efax-[0-9]*
diff --git a/comms/ems-flasher/Makefile b/comms/ems-flasher/Makefile
index ff9615781f9..9c5fe1adb65 100644
--- a/comms/ems-flasher/Makefile
+++ b/comms/ems-flasher/Makefile
@@ -20,7 +20,7 @@ LICENSE= MIT
USE_GMAKE= yes
CFLAGS+= -g -Wall
LDFLAGS+= -lusb
-USE_GCC= 4.6+
+USE_GCC= yes
PLIST_FILES= bin/ems-flasher