aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /comms
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-graphics-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'comms')
-rw-r--r--comms/p5-SMS-Send-TW-Socket2Air/Makefile8
-rw-r--r--comms/p5-SMS-Send-TW-chtsns/Makefile2
-rw-r--r--comms/p5-SMS-Send/Makefile8
3 files changed, 3 insertions, 15 deletions
diff --git a/comms/p5-SMS-Send-TW-Socket2Air/Makefile b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
index b2df499c301..ad9868cd017 100644
--- a/comms/p5-SMS-Send-TW-Socket2Air/Makefile
+++ b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= SMS::Send::TW::Socket2Air.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-IGNORE= perl 5.10 or above is required
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/p5-SMS-Send-TW-chtsns/Makefile b/comms/p5-SMS-Send-TW-chtsns/Makefile
index 1e9ea500bcd..cb81a7b22f9 100644
--- a/comms/p5-SMS-Send-TW-chtsns/Makefile
+++ b/comms/p5-SMS-Send-TW-chtsns/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= p5-SMS-Send>=0:${PORTSDIR}/comms/p5-SMS-Send \
p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= 5.10+
+PERL_CONFIGURE= yes
MAN3= SMS::Send::TW::chtsns.3
diff --git a/comms/p5-SMS-Send/Makefile b/comms/p5-SMS-Send/Makefile
index 7146b28a40d..415d51f99cd 100644
--- a/comms/p5-SMS-Send/Makefile
+++ b/comms/p5-SMS-Send/Makefile
@@ -26,10 +26,4 @@ MAN3= SMS::Send.3 \
SMS::Send::Driver.3 \
SMS::Send::Test.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= p5-Module-Pluggable>=2.5:${PORTSDIR}/devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>