aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
committerflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
commit279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19 (patch)
tree2de93387d7ad1df58a7807b573d91395f20dccb9 /converters
parent604a42f7a6032c5db4396ed6acc540dc4fc691c4 (diff)
downloadfreebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.gz
freebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.zst
freebsd-ports-graphics-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.zip
readd php 5.3.13 and all its modules as php53*
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile3
-rw-r--r--converters/php53-iconv/Makefile14
-rw-r--r--converters/php53-mbstring/Makefile14
-rw-r--r--converters/php53-mbstring/files/patch-config.m451
-rw-r--r--converters/php53-recode/Makefile14
5 files changed, 96 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index c4a1be9f469..e533f617a84 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -126,6 +126,9 @@
SUBDIR += php52-iconv
SUBDIR += php52-mbstring
SUBDIR += php52-recode
+ SUBDIR += php53-iconv
+ SUBDIR += php53-mbstring
+ SUBDIR += php53-recode
SUBDIR += psiconv
SUBDIR += py-bsdconv
SUBDIR += py-iconv
diff --git a/converters/php53-iconv/Makefile b/converters/php53-iconv/Makefile
new file mode 100644
index 00000000000..617b1bf6aea
--- /dev/null
+++ b/converters/php53-iconv/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-iconv
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php53-mbstring/Makefile b/converters/php53-mbstring/Makefile
new file mode 100644
index 00000000000..42ccea395d6
--- /dev/null
+++ b/converters/php53-mbstring/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-mbstring
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php53-mbstring/files/patch-config.m4 b/converters/php53-mbstring/files/patch-config.m4
new file mode 100644
index 00000000000..026798f26a5
--- /dev/null
+++ b/converters/php53-mbstring/files/patch-config.m4
@@ -0,0 +1,51 @@
+--- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
++++ config.m4 2010-04-12 09:59:54.000000000 +0200
+@@ -43,6 +43,30 @@
+ PHP_ADD_INCLUDE([$ext_builddir/$dir])
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$ext_shared" = "no"; then
+ PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
+ out="php_config.h"
+@@ -80,7 +104,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
+@@ -347,6 +370,9 @@
+ [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+
diff --git a/converters/php53-recode/Makefile b/converters/php53-recode/Makefile
new file mode 100644
index 00000000000..b7671b0035a
--- /dev/null
+++ b/converters/php53-recode/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-recode
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -recode
+
+.include "${MASTERDIR}/Makefile"