aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-06-29 23:01:17 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-06-29 23:01:17 +0800
commitf8305c696d7add43bc2cd23461ebddb441b30307 (patch)
tree468fdf956af43a4f114652b233f6d2298415fa56 /converters
parent8865465378820094124d59c4e6612f4815c52676 (diff)
downloadfreebsd-ports-graphics-f8305c696d7add43bc2cd23461ebddb441b30307.tar.gz
freebsd-ports-graphics-f8305c696d7add43bc2cd23461ebddb441b30307.tar.zst
freebsd-ports-graphics-f8305c696d7add43bc2cd23461ebddb441b30307.zip
Converts OSM planet.osm data to a PostgreSQL database suitable
for rendering into map tiles by Mapnik. The format of the database is optimised for ease of rendering by mapnik. It may be less suitable for other general purpose processing. WWW: http://wiki.openstreetmap.org/wiki/Osm2pgsql
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/osm2pgsql/Makefile49
-rw-r--r--converters/osm2pgsql/distinfo2
-rw-r--r--converters/osm2pgsql/pkg-descr8
-rw-r--r--converters/osm2pgsql/pkg-plist21
5 files changed, 81 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 30eb323ceba..9d23d1f23c5 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -49,6 +49,7 @@
SUBDIR += nomyso
SUBDIR += o3read
SUBDIR += osm2mp
+ SUBDIR += osm2pgsql
SUBDIR += p5-Boulder
SUBDIR += p5-Convert-ASCII-Armour
SUBDIR += p5-Convert-ASN1
diff --git a/converters/osm2pgsql/Makefile b/converters/osm2pgsql/Makefile
new file mode 100644
index 00000000000..054c4736388
--- /dev/null
+++ b/converters/osm2pgsql/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: osm2pgsql
+# Date created: 29 Jun 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osm2pgsql
+PORTVERSION= r26200
+CATEGORIES= converters geography
+MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Convert OSM XML data to PostgreSQL database
+
+LIB_DEPENDS= proj.6:${PORTSDIR}/graphics/proj \
+ geos.0:${PORTSDIR}/graphics/geos \
+ protobuf-c.0:${PORTSDIR}/devel/protobuf-c
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf automake libtool aclocal autoheader libtoolize
+USE_GMAKE= yes
+USE_PGSQL= yes
+USE_GNOME= libxml2
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= ChangeLog README AUTHORS TODO
+
+MAN1= osm2pgsql.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/m4/*.m4
+
+run-autotools:
+ cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./autogen.sh
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/converters/osm2pgsql/distinfo b/converters/osm2pgsql/distinfo
new file mode 100644
index 00000000000..03d2cc03eb3
--- /dev/null
+++ b/converters/osm2pgsql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (osm2pgsql-r26200.tar.bz2) = dfbd9d710c0d4f317b53132a22bf92a7f93234b934e16b8bdd9eaf800d8c27e4
+SIZE (osm2pgsql-r26200.tar.bz2) = 25561601
diff --git a/converters/osm2pgsql/pkg-descr b/converters/osm2pgsql/pkg-descr
new file mode 100644
index 00000000000..2ec63816dc2
--- /dev/null
+++ b/converters/osm2pgsql/pkg-descr
@@ -0,0 +1,8 @@
+Converts OSM planet.osm data to a PostgreSQL database suitable
+for rendering into map tiles by Mapnik.
+
+The format of the database is optimised for ease of rendering
+by mapnik. It may be less suitable for other general purpose
+processing.
+
+WWW: http://wiki.openstreetmap.org/wiki/Osm2pgsql
diff --git a/converters/osm2pgsql/pkg-plist b/converters/osm2pgsql/pkg-plist
new file mode 100644
index 00000000000..02a9273ca85
--- /dev/null
+++ b/converters/osm2pgsql/pkg-plist
@@ -0,0 +1,21 @@
+bin/osm2pgsql
+lib/osm2pgsql/gazetteer.la
+lib/osm2pgsql/gazetteer.so
+share/gazetteer/extract_countrynames.sql
+share/gazetteer/gazetteer-functions.sql
+share/gazetteer/gazetteer-index.sql
+share/gazetteer/gazetteer-loaddata.sql
+share/gazetteer/gazetteer-tables.sql
+share/gazetteer/import_country_name.sql
+share/gazetteer/import_country_osm_grid.sql
+share/gazetteer/import_gb_postcode.sql
+share/gazetteer/import_gb_postcodearea.sql
+share/gazetteer/import_specialwords.sql
+share/gazetteer/import_us_state.sql
+share/gazetteer/import_us_statecounty.sql
+share/gazetteer/import_worldboundaries.sql
+%%DATADIR%%/900913.sql
+%%DATADIR%%/default.style
+@dirrm %%DATADIR%%
+@dirrm share/gazetteer
+@dirrm lib/osm2pgsql