aboutsummaryrefslogtreecommitdiffstats
path: root/databases/c3p0
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-21 17:50:40 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-21 17:50:40 +0800
commit8c6a300bea9ebaea1f2e2244cad22717dd886565 (patch)
treec515f98f923bf156181cceafb7ce67089ebfee52 /databases/c3p0
parent63977f910707dc500d020265ef8031bbc9ac53fc (diff)
downloadfreebsd-ports-graphics-8c6a300bea9ebaea1f2e2244cad22717dd886565.tar.gz
freebsd-ports-graphics-8c6a300bea9ebaea1f2e2244cad22717dd886565.tar.zst
freebsd-ports-graphics-8c6a300bea9ebaea1f2e2244cad22717dd886565.zip
Upgrade to version 0.9.5.1.
- Add LICENSE - Remove unnecessary OPTIONS_DEFINE - Fix portlint warnings - Use actual home page in WWW tag
Diffstat (limited to 'databases/c3p0')
-rw-r--r--databases/c3p0/Makefile9
-rw-r--r--databases/c3p0/distinfo4
-rw-r--r--databases/c3p0/pkg-descr2
-rw-r--r--databases/c3p0/pkg-plist13
4 files changed, 13 insertions, 15 deletions
diff --git a/databases/c3p0/Makefile b/databases/c3p0/Makefile
index cfa1e04bd05..ebd376795e6 100644
--- a/databases/c3p0/Makefile
+++ b/databases/c3p0/Makefile
@@ -1,22 +1,23 @@
# $FreeBSD$
PORTNAME= c3p0
-PORTVERSION= 0.9.5
+PORTVERSION= 0.9.5.1
CATEGORIES= databases java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-bin/${PORTNAME}-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.bin
-EXTRACT_SUFX= .tgz
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Library for augmenting JDBC drivers with JNDI-bindable DataSources
+LICENSE= LGPL21 EPL
+LICENSE_COMB= dual
+
+USES= tar:tgz
USE_JAVA= yes
NO_BUILD= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS_DEFINE= DOCS
-
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/databases/c3p0/distinfo b/databases/c3p0/distinfo
index b7806878961..fea4a84bcc1 100644
--- a/databases/c3p0/distinfo
+++ b/databases/c3p0/distinfo
@@ -1,2 +1,2 @@
-SHA256 (c3p0-0.9.5.bin.tgz) = 5d69a93b26fd93283c5b52805fb300eda4ec9254c0f15485e2872238c3627023
-SIZE (c3p0-0.9.5.bin.tgz) = 2352176
+SHA256 (c3p0-0.9.5.1.bin.tgz) = 02381e190872f591fdd3f7984a07955051cf47df242177d4ca7a647da615ad41
+SIZE (c3p0-0.9.5.1.bin.tgz) = 2381734
diff --git a/databases/c3p0/pkg-descr b/databases/c3p0/pkg-descr
index 508c3c4e9d8..ba8a51323de 100644
--- a/databases/c3p0/pkg-descr
+++ b/databases/c3p0/pkg-descr
@@ -3,4 +3,4 @@ c3p0 is an easy-to-use Java library for augmenting traditional
including DataSources that implement Connection and Statement
Pooling, as described by the jdbc3 spec and jdbc2 std extension.
-WWW: http://sourceforge.net/projects/c3p0/
+WWW: http://www.mchange.com/projects/c3p0/
diff --git a/databases/c3p0/pkg-plist b/databases/c3p0/pkg-plist
index 7f95ed54002..ef809bb3137 100644
--- a/databases/c3p0/pkg-plist
+++ b/databases/c3p0/pkg-plist
@@ -11,10 +11,7 @@
%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/index.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/overview-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/package-list
-%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/resources/background.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/resources/tab.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/resources/titlebar.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/resources/titlebar_end.gif
+%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/script.js
%%PORTDOCS%%%%DOCSDIR%%/apidocs-oracle-thin/stylesheet.css
%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-frame.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/allclasses-noframe.html
@@ -59,10 +56,12 @@
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/AfterCloseLoggingConnectionWrapper.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/CloseLoggingComboPooledDataSource.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/CloseLoggingConnectionWrapper.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/ConstructionLoggingComboPooledDataSource.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/package-frame.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/package-summary.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/debug/package-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/example/InitSqlConnectionCustomizer.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/example/IsValidOnlyConnectionTester30.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/example/package-frame.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/example/package-summary.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/example/package-tree.html
@@ -174,6 +173,7 @@
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/test/package-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/CloseReportingConnectionWrapper.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/ConnectionEventSupport.html
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/IsValidOnlyConnectionTester.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/StatementEventSupport.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/TestUtils.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/com/mchange/v2/c3p0/util/package-frame.html
@@ -203,10 +203,7 @@
%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-summary.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/overview-tree.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/package-list
-%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/background.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/tab.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/titlebar.gif
-%%PORTDOCS%%%%DOCSDIR%%/apidocs/resources/titlebar_end.gif
+%%PORTDOCS%%%%DOCSDIR%%/apidocs/script.js
%%PORTDOCS%%%%DOCSDIR%%/apidocs/serialized-form.html
%%PORTDOCS%%%%DOCSDIR%%/apidocs/stylesheet.css
%%PORTDOCS%%%%DOCSDIR%%/arrow_sm.png