aboutsummaryrefslogtreecommitdiffstats
path: root/databases/cego/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-24 17:54:22 +0800
committerbapt <bapt@FreeBSD.org>2011-04-24 17:54:22 +0800
commit68f083332cf80eecfde65cae1ab2540277027fab (patch)
tree5d64fb068da613fdca7d2062c622e783f3aed788 /databases/cego/Makefile
parenta0f6498cde343524ebde48bd7c9bb72556eed9fa (diff)
downloadfreebsd-ports-graphics-68f083332cf80eecfde65cae1ab2540277027fab.tar.gz
freebsd-ports-graphics-68f083332cf80eecfde65cae1ab2540277027fab.tar.zst
freebsd-ports-graphics-68f083332cf80eecfde65cae1ab2540277027fab.zip
- update to 2.8.3
- use of USERS/GROUPS macros - add rc script PR: ports/155405 Submitted by: Kurt Jaeger <fbsd-ports _at_ opsec.eu> (maintainer)
Diffstat (limited to 'databases/cego/Makefile')
-rw-r--r--databases/cego/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index b473fe44956..6caf7c149b3 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= cego
-PORTVERSION= 2.6.18
+PORTVERSION= 2.8.3
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
@@ -21,5 +21,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf:env
+USE_RC_SUBR= cego
+
+USE_NCURSES= yes
+
+USERS= cego
+GROUPS= cego
+
+PLIST_SUB+= USER=${USERS}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O3,,g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>