aboutsummaryrefslogtreecommitdiffstats
path: root/databases/dbtool
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /databases/dbtool
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-graphics-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'databases/dbtool')
-rw-r--r--databases/dbtool/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/dbtool/Makefile b/databases/dbtool/Makefile
index 00d59f3f674..aaf1776352c 100644
--- a/databases/dbtool/Makefile
+++ b/databases/dbtool/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${DB_INC}"
USE_GMAKE= yes
+USE_REINPLACE= yes
MAN1= dbtool.1
@@ -42,8 +43,8 @@ post-extract:
post-patch:
.for file in dbtool.cc engine.cc engine.h
- @${PERL} -pi -e "s,stdin,input,g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s,stdin,input,g" ${WRKSRC}/${file}
.endfor
- @${PERL} -pi -e "s,==,=,g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s,==,=,g" ${WRKSRC}/configure
.include <bsd.port.mk>