aboutsummaryrefslogtreecommitdiffstats
path: root/databases/glom
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /databases/glom
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-graphics-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'databases/glom')
-rw-r--r--databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc20
1 files changed, 20 insertions, 0 deletions
diff --git a/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc b/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc
new file mode 100644
index 00000000000..a83ec8738c2
--- /dev/null
+++ b/databases/glom/files/patch-glom-libglom-python_embed-py_glom_record.cc
@@ -0,0 +1,20 @@
+--- glom/libglom/python_embed/py_glom_record.cc.orig Sun Jul 15 13:34:18 2007
++++ glom/libglom/python_embed/py_glom_record.cc Sun Jul 15 13:34:44 2007
+@@ -122,7 +122,7 @@
+
+
+
+-static int
++static Py_ssize_t
+ Record_tp_as_mapping_length(PyGlomRecord *self)
+ {
+ return self->m_pMap_field_values->size();
+@@ -146,7 +146,7 @@
+ }
+ else
+ {
+- g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", self->m_pMap_field_values->size(), pchKey);
++ g_warning("Record_tp_as_mapping_getitem(): item not found in m_pMap_field_values. size=%d, item=%s", (int)self->m_pMap_field_values->size(), pchKey);
+ }
+ }
+ else