aboutsummaryrefslogtreecommitdiffstats
path: root/databases/kbibtex
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2005-11-08 22:30:37 +0800
committermarkus <markus@FreeBSD.org>2005-11-08 22:30:37 +0800
commitd04d7ce246aff997de0176da0ec294bb2c12ca5a (patch)
tree9e535d9a20cc2bcdb8f108e854dd1af99f3de180 /databases/kbibtex
parent77167ca88f31a64129bd10ea73c1de3e4246706a (diff)
downloadfreebsd-ports-graphics-d04d7ce246aff997de0176da0ec294bb2c12ca5a.tar.gz
freebsd-ports-graphics-d04d7ce246aff997de0176da0ec294bb2c12ca5a.tar.zst
freebsd-ports-graphics-d04d7ce246aff997de0176da0ec294bb2c12ca5a.zip
- Add patch in order to fix a major bug where @string elements won't be saved
- Bump PORTREVISION
Diffstat (limited to 'databases/kbibtex')
-rw-r--r--databases/kbibtex/Makefile2
-rw-r--r--databases/kbibtex/files/patch-bibtexstring.cpp10
2 files changed, 11 insertions, 1 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 5905f1d76f1..494673218e3 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kbibtex
PORTVERSION= 0.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases kde
MASTER_SITES= http://www.unix-ag.uni-kl.de/~fischer/${PORTNAME}/download/
diff --git a/databases/kbibtex/files/patch-bibtexstring.cpp b/databases/kbibtex/files/patch-bibtexstring.cpp
new file mode 100644
index 00000000000..25f83bc339b
--- /dev/null
+++ b/databases/kbibtex/files/patch-bibtexstring.cpp
@@ -0,0 +1,10 @@
+--- src/bibtexstring.cpp.orig Tue Nov 8 13:07:00 2005
++++ src/bibtexstring.cpp Tue Nov 8 13:07:40 2005
+@@ -112,6 +112,7 @@
+ else result.append( "\"" );
+
+ result.append( " }" );
++ return result;
+ }
+ break;
+ case BibTeXFile::formatXML: