aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libsdb
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-16 21:48:55 +0800
committerkrion <krion@FreeBSD.org>2004-03-16 21:48:55 +0800
commit356e6d2ddbc8cf0b4cbb5a5eab8956e44e5ac854 (patch)
tree9ef6d29dca527e02f8158c1701430de23ecbf133 /databases/libsdb
parent01ac8ceff98fc099f172ee9805a892d5b41d6c82 (diff)
downloadfreebsd-ports-graphics-356e6d2ddbc8cf0b4cbb5a5eab8956e44e5ac854.tar.gz
freebsd-ports-graphics-356e6d2ddbc8cf0b4cbb5a5eab8956e44e5ac854.tar.zst
freebsd-ports-graphics-356e6d2ddbc8cf0b4cbb5a5eab8956e44e5ac854.zip
- Update to version 0.5.2
PR: ports/64331 Submitted by: Ports Fury
Diffstat (limited to 'databases/libsdb')
-rw-r--r--databases/libsdb/Makefile10
-rw-r--r--databases/libsdb/distinfo4
-rw-r--r--databases/libsdb/files/patch-ltmain.sh41
3 files changed, 9 insertions, 46 deletions
diff --git a/databases/libsdb/Makefile b/databases/libsdb/Makefile
index 5ecefcced10..92bec03bf48 100644
--- a/databases/libsdb/Makefile
+++ b/databases/libsdb/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libsdb
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
CATEGORIES= databases
MASTER_SITES= ftp://siag.nu/pub/libsdb/ \
http://siag.nu/pub/libsdb/
@@ -16,11 +16,15 @@ DISTNAME= sdb-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple database library
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnometarget lthack
+USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
MAN3= sdb.3 sdb_init.3 sdb_open.3 sdb_close.3 sdb_query.3
MAN8= sdbd.8
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|= -lsdb|= $$(top_builddir)/libsdb.la|g' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/databases/libsdb/distinfo b/databases/libsdb/distinfo
index 16d62ac5a73..cbf422ee404 100644
--- a/databases/libsdb/distinfo
+++ b/databases/libsdb/distinfo
@@ -1,2 +1,2 @@
-MD5 (sdb-0.5.1.tar.gz) = c37ea7ba086da341def577fde66fe57b
-SIZE (sdb-0.5.1.tar.gz) = 236028
+MD5 (sdb-0.5.2.tar.gz) = bcc84f84914a7c4ebb5953eec331ab15
+SIZE (sdb-0.5.2.tar.gz) = 259220
diff --git a/databases/libsdb/files/patch-ltmain.sh b/databases/libsdb/files/patch-ltmain.sh
deleted file mode 100644
index 4ecdfcd9180..00000000000
--- a/databases/libsdb/files/patch-ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- ltmain.sh.orig Fri Dec 21 07:33:52 2001
-+++ ltmain.sh Sun Nov 3 09:48:46 2002
-@@ -1043,14 +1043,14 @@
- # These systems don't actually have a C library (as such)
- test "X$arg" = "X-lc" && continue
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-frebsd*)
- # Do not include libc due to us having libc/libc_r.
- test "X$arg" = "X-lc" && continue
- ;;
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -2441,7 +2441,7 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-- *-*-openbsd*)
-+ *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
- ;;
- *)
-@@ -4210,10 +4210,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"