aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql-connector-odbc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-06 00:24:00 +0800
committerbapt <bapt@FreeBSD.org>2014-05-06 00:24:00 +0800
commit602652f5f498977ca9afddad82ce1abd529c8fdb (patch)
tree111c3e996440f35b3a05e66700954340c9919761 /databases/mysql-connector-odbc
parentc7c57f6ff3ff10dcbd4c447d7f21425e9de38302 (diff)
downloadfreebsd-ports-graphics-602652f5f498977ca9afddad82ce1abd529c8fdb.tar.gz
freebsd-ports-graphics-602652f5f498977ca9afddad82ce1abd529c8fdb.tar.zst
freebsd-ports-graphics-602652f5f498977ca9afddad82ce1abd529c8fdb.zip
Fix unixODBC vs libiodbc conflicts
Always rely on unixODBC each time a port is looking for libodbc.so Remove odbc compat from libiodbc This allows to install both kde and gnome at the same time While here: - Convert libiodbc to USES=libtool - Convert a bunch of libiodbc dependencies to USES=libtool - Chase libiodbc.so shlib change - Stagify some ports - Convert some ports to USES=pgsql Discussed with: rakuco (kde) With hat: portmgr
Diffstat (limited to 'databases/mysql-connector-odbc')
-rw-r--r--databases/mysql-connector-odbc/Makefile17
1 files changed, 0 insertions, 17 deletions
diff --git a/databases/mysql-connector-odbc/Makefile b/databases/mysql-connector-odbc/Makefile
index a376913f8e6..7b67490dfaa 100644
--- a/databases/mysql-connector-odbc/Makefile
+++ b/databases/mysql-connector-odbc/Makefile
@@ -21,26 +21,9 @@ PLIST_SUB= VER=${PORTVERSION}
PORTDOCS= ChangeLog INSTALL \
README README.debug COPYING Licenses_for_Third-Party_Components.txt
-# MyODBC needs an ODBC driver manager to be installed, and it supports both
-# iODBC and unixODBC.
-
-.if defined(WITH_IODBC) && defined(WITH_UNIXODBC)
-IGNORE= selected mutually exclusive options: WITH_IODBC and WITH_UNIXODBC
-.endif
-
-.if !defined(WITH_IODBC) && !defined(WITH_UNIXODBC)
-WITH_UNIXODBC?= yes
-.endif
-
-.if defined(WITH_UNIXODBC)
LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
BUILD_DEPENDS= unixODBC>=2.2.14_1:${PORTSDIR}/databases/unixODBC
CMAKE_ARGS += -DWITH_UNIXODBC=1
DRIVER_MANAGER= unixodbc
-.elif defined(WITH_IODBC)
-LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
-DRIVER_MANAGER= iodbc
-CFLAGS+= -I${LOCALBASE}/include
-.endif
.include <bsd.port.mk>