aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql41-server/files
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-01-06 05:03:03 +0800
committerdirk <dirk@FreeBSD.org>2000-01-06 05:03:03 +0800
commitb95abd92757da050a7391ccb121c985c891cda81 (patch)
tree95fcfa8c2bb43d5c586d81d87387b474839a249f /databases/mysql41-server/files
parent25131cb82a8efdffd0f00f9330110834f900e902 (diff)
downloadfreebsd-ports-graphics-b95abd92757da050a7391ccb121c985c891cda81.tar.gz
freebsd-ports-graphics-b95abd92757da050a7391ccb121c985c891cda81.tar.zst
freebsd-ports-graphics-b95abd92757da050a7391ccb121c985c891cda81.zip
- upgrade to 3.22.29
- add -O0 for compiling sql/sql_yacc.cc. Otherwise gcc eats a lot of memory and cpu time. It seems to be a gcc compiler bug in conjunction with -O.
Diffstat (limited to 'databases/mysql41-server/files')
-rw-r--r--databases/mysql41-server/files/patch-Makefile.in15
-rw-r--r--databases/mysql41-server/files/patch-ap18
-rw-r--r--databases/mysql41-server/files/patch-aq13
-rw-r--r--databases/mysql41-server/files/patch-include::Makefile.in14
4 files changed, 43 insertions, 17 deletions
diff --git a/databases/mysql41-server/files/patch-Makefile.in b/databases/mysql41-server/files/patch-Makefile.in
index ca368054999..00190736f76 100644
--- a/databases/mysql41-server/files/patch-Makefile.in
+++ b/databases/mysql41-server/files/patch-Makefile.in
@@ -1,16 +1,15 @@
---- Makefile.in.orig Sun Jun 6 04:51:50 1999
-+++ Makefile.in Sat Jun 26 08:53:51 1999
-@@ -141,8 +141,11 @@
+--- Makefile.in.orig Sat Jan 1 17:59:38 2000
++++ Makefile.in Mon Jan 3 17:19:23 2000
+@@ -144,7 +144,11 @@
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE-GENERIC README PUBLIC INSTALL-SOURCE MIRRORS
--SUBDIRS = @docs_dirs@ @readline_dir@ client @sql_server_dirs@ scripts include tests man @bench_dirs@ support-files
--
+-SUBDIRS = include @docs_dirs@ @readline_dir@ client @sql_server_dirs@ scripts tests man @bench_dirs@ support-files
+.if defined(CLIENT_ONLY)
-+SUBDIRS = @readline_dir@ client include tests man
++SUBDIRS = include @readline_dir@ client tests man
+.else
-+SUBDIRS = @docs_dirs@ @sql_server_dirs@ scripts @bench_dirs@ support-files
++SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts @bench_dirs@ support-files
+.endif
+
# Relink after clean
- CLEANFILES = linked_client_sources
diff --git a/databases/mysql41-server/files/patch-ap b/databases/mysql41-server/files/patch-ap
index f42968f78ee..097b449a181 100644
--- a/databases/mysql41-server/files/patch-ap
+++ b/databases/mysql41-server/files/patch-ap
@@ -1,11 +1,11 @@
---- strings/Makefile.in.orig Thu Sep 9 10:52:02 1999
-+++ strings/Makefile.in Sun Sep 12 23:56:25 1999
-@@ -143,7 +143,7 @@
+--- strings/Makefile.in.orig Sat Jan 1 18:00:30 2000
++++ strings/Makefile.in Mon Jan 3 17:21:19 2000
+@@ -145,7 +145,7 @@
+ INCLUDES = @MT_INCLUDES@ -I$(srcdir)/../include -I../include
pkglib_LIBRARIES = libmystrings.a
+ #no assembler
+-@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.s longlong2str-x86.s
++@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.S longlong2str-x86.S
+ @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_TRUE@ASRCS = bmove_upp-sparc.s strappend-sparc.s strend-sparc.s strinstr-sparc.s strmake-sparc.s strmov-sparc.s strnmov-sparc.s strstr-sparc.s strxmov-sparc.s
+ @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_FALSE@ASRCS =
# These file MUST all be on the same line!! Otherwise automake
- # generats a very broken makefile
--@ASSEMBLER_TRUE@ESRCS = strings.s longlong2str-x86.s
-+@ASSEMBLER_TRUE@ESRCS = strings.S longlong2str-x86.S
- @ASSEMBLER_FALSE@ESRCS = strxmov.c bmove_upp.c strappend.c strcont.c strend.c strfill.c strcend.c is_prefix.c strstr.c strinstr.c strmake.c strnmov.c strmov.c longlong2str.c
-
- libmystrings_a_SOURCES = bfill.c bmove.c bmove512.c bchange.c strxnmov.c int2str.c str2int.c r_strinstr.c ct_init.c atof.c ptr_cmp.c bcmp.c strtol.c strtoul.c strtoll.c strtoull.c @CHARSET_SRCS@ $(ESRCS)
diff --git a/databases/mysql41-server/files/patch-aq b/databases/mysql41-server/files/patch-aq
new file mode 100644
index 00000000000..57332417592
--- /dev/null
+++ b/databases/mysql41-server/files/patch-aq
@@ -0,0 +1,13 @@
+--- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
++++ sql/Makefile.in Wed Jan 5 20:28:17 2000
+@@ -317,6 +317,10 @@
+ else :; fi
+ sql_yacc.hh: sql_yacc.cc
+
++# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
++sql_yacc.o: sql_yacc.cc
++ $(CXXCOMPILE) -O0 -c $<
++
+
+ # This directory's subdirectories are mostly independent; you can cd
+ # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql41-server/files/patch-include::Makefile.in b/databases/mysql41-server/files/patch-include::Makefile.in
new file mode 100644
index 00000000000..ed7654838e6
--- /dev/null
+++ b/databases/mysql41-server/files/patch-include::Makefile.in
@@ -0,0 +1,14 @@
+--- include/Makefile.in.orig Sat Jan 1 17:59:41 2000
++++ include/Makefile.in Wed Jan 5 21:04:23 2000
+@@ -259,7 +259,11 @@
+
+ install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
++.if defined(CLIENT_ONLY)
+ install: install-am
++.else
++install:
++.endif
+ uninstall-am: uninstall-pkgincludeHEADERS
+ uninstall: uninstall-am
+ all-am: Makefile $(HEADERS) all-local