aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ocaml-pgocaml
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-03-02 08:22:36 +0800
committerpav <pav@FreeBSD.org>2009-03-02 08:22:36 +0800
commit1d5ff031a63668457427831be1f01d6d833ca155 (patch)
tree919e2f4f86ac34b51cc1dc3d1d0253dde880a8e9 /databases/ocaml-pgocaml
parentb398ae30d32743d5b21ceb1f4b4d656d155b3125 (diff)
downloadfreebsd-ports-graphics-1d5ff031a63668457427831be1f01d6d833ca155.tar.gz
freebsd-ports-graphics-1d5ff031a63668457427831be1f01d6d833ca155.tar.zst
freebsd-ports-graphics-1d5ff031a63668457427831be1f01d6d833ca155.zip
- Update to 1.1
Submitted by: Thomas Crimi <tcrimi@gmail.com> (maintainer)
Diffstat (limited to 'databases/ocaml-pgocaml')
-rw-r--r--databases/ocaml-pgocaml/Makefile5
-rw-r--r--databases/ocaml-pgocaml/distinfo6
-rw-r--r--databases/ocaml-pgocaml/files/patch-Makefile14
-rw-r--r--databases/ocaml-pgocaml/files/patch-pGOCaml.ml10
-rw-r--r--databases/ocaml-pgocaml/files/patch-pGOCaml.mli11
5 files changed, 26 insertions, 20 deletions
diff --git a/databases/ocaml-pgocaml/Makefile b/databases/ocaml-pgocaml/Makefile
index 987cb382fd8..dddbe17f82b 100644
--- a/databases/ocaml-pgocaml/Makefile
+++ b/databases/ocaml-pgocaml/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= pgocaml
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.1
CATEGORIES= databases
-MASTER_SITES= http://merjis.com/_file/
+MASTER_SITES= BERLIOS
PKGNAMEPREFIX= ocaml-
MAINTAINER= tcrimi@gmail.com
diff --git a/databases/ocaml-pgocaml/distinfo b/databases/ocaml-pgocaml/distinfo
index 3c2a0ca66b8..2a07ffcecd3 100644
--- a/databases/ocaml-pgocaml/distinfo
+++ b/databases/ocaml-pgocaml/distinfo
@@ -1,3 +1,3 @@
-MD5 (pgocaml-1.0.tar.gz) = 4f12ab37e75cc863560600e458e202d5
-SHA256 (pgocaml-1.0.tar.gz) = 57116434f10d50a72e62425e78619091162e7458005ab3301b60e16138873ad8
-SIZE (pgocaml-1.0.tar.gz) = 36288
+MD5 (pgocaml-1.1.tar.gz) = e52d0f88b4ce850aa592a033c7e7b64d
+SHA256 (pgocaml-1.1.tar.gz) = 9ab3808bb9f2f29bf12a80aac8ca722524b7d6e0e75a1f1a9be5058322be665a
+SIZE (pgocaml-1.1.tar.gz) = 37039
diff --git a/databases/ocaml-pgocaml/files/patch-Makefile b/databases/ocaml-pgocaml/files/patch-Makefile
index 3dc77d5d62f..208039919c7 100644
--- a/databases/ocaml-pgocaml/files/patch-Makefile
+++ b/databases/ocaml-pgocaml/files/patch-Makefile
@@ -20,17 +20,3 @@
ifeq ($(wildcard .depend),.depend)
include .depend
-@@ -109,11 +109,11 @@
- # Install.
-
- findlib_install:
-- ocamlfind install pgocaml META pgocaml.{,cm{,x}}a pGOCaml.cm[ix] pa_pgsql.cmo
-+ ocamlfind install pgocaml META pgocaml.*a pGOCaml.cm[ix] pa_pgsql.cmo
-
- reinstall:
- ocamlfind remove pgocaml
-- ocamlfind install pgocaml META pgocaml.{,cm{,x}}a pGOCaml.cm[ix] pa_pgsql.cmo
-+ ocamlfind install pgocaml META pgocaml.*a pGOCaml.cm[ix] pa_pgsql.cmo
-
- install:
- rm -rf $(DESTDIR)$(OCAMLLIBDIR)/pgocaml
diff --git a/databases/ocaml-pgocaml/files/patch-pGOCaml.ml b/databases/ocaml-pgocaml/files/patch-pGOCaml.ml
new file mode 100644
index 00000000000..a8063e954a4
--- /dev/null
+++ b/databases/ocaml-pgocaml/files/patch-pGOCaml.ml
@@ -0,0 +1,10 @@
+--- pGOCaml.ml.orig 2009-03-01 09:59:13.864728737 -0500
++++ pGOCaml.ml 2009-03-01 09:59:53.353002107 -0500
+@@ -22,6 +22,7 @@
+
+ open Printf
+ open ExtString
++open CalendarLib
+
+ type 'a t = {
+ ichan : in_channel; (* In_channel wrapping socket. *)
diff --git a/databases/ocaml-pgocaml/files/patch-pGOCaml.mli b/databases/ocaml-pgocaml/files/patch-pGOCaml.mli
new file mode 100644
index 00000000000..169e264c41b
--- /dev/null
+++ b/databases/ocaml-pgocaml/files/patch-pGOCaml.mli
@@ -0,0 +1,11 @@
+--- pGOCaml.mli.orig 2009-03-01 09:59:09.188523102 -0500
++++ pGOCaml.mli 2009-03-01 09:59:43.562605632 -0500
+@@ -20,6 +20,8 @@
+ * Boston, MA 02111-1307, USA.
+ *)
+
++open CalendarLib
++
+ type 'a t (** Database handle. *)
+
+ exception Error of string