aboutsummaryrefslogtreecommitdiffstats
path: root/databases/opentsdb
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-15 01:17:05 +0800
committermat <mat@FreeBSD.org>2015-12-15 01:17:05 +0800
commitf2a2c753f8ad7d986e5ff2f7c2770ce66a94d81b (patch)
tree4cebff14c50808ace07eac5d20661188d32c1a9c /databases/opentsdb
parent8907ee8af3faa5400bfd4a7ae41619ecbd8fe641 (diff)
downloadfreebsd-ports-graphics-f2a2c753f8ad7d986e5ff2f7c2770ce66a94d81b.tar.gz
freebsd-ports-graphics-f2a2c753f8ad7d986e5ff2f7c2770ce66a94d81b.tar.zst
freebsd-ports-graphics-f2a2c753f8ad7d986e5ff2f7c2770ce66a94d81b.zip
Fix build as a user.
While there, really don't generate backup copies in post-patch. Sponsored by: Absolight
Diffstat (limited to 'databases/opentsdb')
-rw-r--r--databases/opentsdb/Makefile8
-rw-r--r--databases/opentsdb/files/patch-Makefile.in10
2 files changed, 11 insertions, 7 deletions
diff --git a/databases/opentsdb/Makefile b/databases/opentsdb/Makefile
index 30f56b59c8e..cc76b050844 100644
--- a/databases/opentsdb/Makefile
+++ b/databases/opentsdb/Makefile
@@ -44,10 +44,10 @@ SUB_LIST= OPENTSDB_USER="${OPENTSDB_USER}" \
OPENTSDB_RUNDIR="${OPENTSDB_RUNDIR}"
post-patch:
- ${REINPLACE_CMD} -i"" -e "s|python|${PYTHON_CMD}|" ${WRKSRC}/build-aux/gen_build_data.sh
- ${REINPLACE_CMD} -i"" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -i"" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/src/utils/Config.java
- ${REINPLACE_CMD} -i"" -e "s|tsd.http.staticroot =|tsd.http.staticroot = ${DATADIR}/static|; s|tsd.http.cachedir =|tsd.http.cachedir = /tmp/opentsdb|; s|tsd.network.port =|tsd.network.port = 4242|;" ${WRKSRC}/src/opentsdb.conf
+ ${REINPLACE_CMD} -i "" -e "s|python|${PYTHON_CMD}|" ${WRKSRC}/build-aux/gen_build_data.sh
+ ${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/src/utils/Config.java
+ ${REINPLACE_CMD} -i "" -e "s|tsd.http.staticroot =|tsd.http.staticroot = ${DATADIR}/static|; s|tsd.http.cachedir =|tsd.http.cachedir = /tmp/opentsdb|; s|tsd.network.port =|tsd.network.port = 4242|;" ${WRKSRC}/src/opentsdb.conf
post-install:
${MKDIR} ${STAGEDIR}${ETCDIR} ${STAGEDIR}${OPENTSDB_LOGDIR} ${STAGEDIR}${OPENTSDB_RUNDIR}
diff --git a/databases/opentsdb/files/patch-Makefile.in b/databases/opentsdb/files/patch-Makefile.in
index 4d71c200db5..69ece9a707f 100644
--- a/databases/opentsdb/files/patch-Makefile.in
+++ b/databases/opentsdb/files/patch-Makefile.in
@@ -1,15 +1,19 @@
--- Makefile.in.orig 2015-09-12 19:49:17 UTC
+++ Makefile.in
-@@ -1415,7 +1415,7 @@ printdeps:
+@@ -1415,9 +1415,11 @@ printdeps:
# This is kind of a hack, but I couldn't find a better way to adjust the paths
# in the script before it gets installed...
install-exec-hook:
- script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(pkgdatadir)/etc/opentsdb'; \
+ script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(sysconfdir)/etc/opentsdb'; \
abs_srcdir=''; abs_builddir=''; $(edit_tsdb_script)
++ chmod u+w "$(DESTDIR)$(bindir)/tsdb"
cat tsdb.tmp >"$(DESTDIR)$(bindir)/tsdb"
++ chmod u-w "$(DESTDIR)$(bindir)/tsdb"
rm -f tsdb.tmp
-@@ -1442,7 +1442,7 @@ gwtc: .gwtc-stamp
+
+ $(builddata_SRC): .git/HEAD $(tsdb_SRC) $(top_srcdir)/build-aux/gen_build_data.sh
+@@ -1442,7 +1444,7 @@ gwtc: .gwtc-stamp
@$(mkdir_p) gwt
{ cd $(srcdir) && cat $(httpui_SRC); } | $(MD5) >"$@-t"
cmp -s "$@" "$@-t" && exit 0; \
@@ -18,7 +22,7 @@
$(GWTC_ARGS) -war gwt tsd.QueryUi
@mv "$@-t" "$@"
gwtdev: .gwtc-stamp
-@@ -1468,7 +1468,7 @@ gwttsd: staticroot
+@@ -1468,7 +1470,7 @@ gwttsd: staticroot
# how to tell it to install a bunch of files recursively for which I don't
# know ahead of time what the file names are.
install-data-local: staticroot install-data-lib install-data-tools \