aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-SQLite2
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /databases/p5-DBD-SQLite2
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'databases/p5-DBD-SQLite2')
-rw-r--r--databases/p5-DBD-SQLite2/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/databases/p5-DBD-SQLite2/Makefile b/databases/p5-DBD-SQLite2/Makefile
index d2a3c236704..237cc38861f 100644
--- a/databases/p5-DBD-SQLite2/Makefile
+++ b/databases/p5-DBD-SQLite2/Makefile
@@ -15,12 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nork@FreeBSD.org
COMMENT= Provides access to SQLite2 databases through the DBI
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::SQLite.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>