aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBZ_File/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-02 16:08:14 +0800
committerwill <will@FreeBSD.org>2000-07-02 16:08:14 +0800
commit2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f (patch)
tree75c235aaaebbbda57ddf52f61a66d5e784bf5c9e /databases/p5-DBZ_File/Makefile
parent89a3e5ac219f726db6a086ad7fe8e9b97b22c891 (diff)
downloadfreebsd-ports-graphics-2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f.tar.gz
freebsd-ports-graphics-2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f.tar.zst
freebsd-ports-graphics-2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f.zip
Add p5-DBZ_File, a perl module for accessing DBZ databases.
PR: 18846 Submitted by; Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
Diffstat (limited to 'databases/p5-DBZ_File/Makefile')
-rw-r--r--databases/p5-DBZ_File/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-DBZ_File/Makefile b/databases/p5-DBZ_File/Makefile
new file mode 100644
index 00000000000..d3b6160d295
--- /dev/null
+++ b/databases/p5-DBZ_File/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-DBZ_File
+# Date created: May 26th 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBZ_File
+PORTVERSION= 1.1
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBZ_File
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+USE_PERL5= yes
+
+WRKSRC= ${WRKDIR}/DBZ_File
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBZ_File.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} -I ${FILESDIR} Makefile.PL \
+ LIBS= INC=-I${FILESDIR} CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>