aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-POE-Component-DBIAgent
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /databases/p5-POE-Component-DBIAgent
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-graphics-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'databases/p5-POE-Component-DBIAgent')
-rw-r--r--databases/p5-POE-Component-DBIAgent/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/databases/p5-POE-Component-DBIAgent/Makefile b/databases/p5-POE-Component-DBIAgent/Makefile
index 7d87457a958..a2fd31cadd1 100644
--- a/databases/p5-POE-Component-DBIAgent/Makefile
+++ b/databases/p5-POE-Component-DBIAgent/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= POE Component for running asynchronous DBI calls
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -27,4 +26,14 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= POE::Component::DBIAgent.3 POE::Component::DBIAgent::Helper.3 \
POE::Component::DBIAgent::Queue.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>