aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pear-DoctrineDBAL
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-20 22:42:30 +0800
committerwg <wg@FreeBSD.org>2013-06-20 22:42:30 +0800
commit72a2c8f876f60dc70630e23bf8dde9026bce6bc1 (patch)
tree2a1b79f4946d2b45d9676215a263fa8f878517f2 /databases/pear-DoctrineDBAL
parente9a472f840a350b0885a51874f4325a91a9e863f (diff)
downloadfreebsd-ports-graphics-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.tar.gz
freebsd-ports-graphics-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.tar.zst
freebsd-ports-graphics-72a2c8f876f60dc70630e23bf8dde9026bce6bc1.zip
The Doctrine DBAL package is the database abstraction layer used to
power the ORM package. WWW: http://www.doctrine-project.org/
Diffstat (limited to 'databases/pear-DoctrineDBAL')
-rw-r--r--databases/pear-DoctrineDBAL/Makefile54
-rw-r--r--databases/pear-DoctrineDBAL/distinfo2
-rw-r--r--databases/pear-DoctrineDBAL/pkg-descr4
3 files changed, 60 insertions, 0 deletions
diff --git a/databases/pear-DoctrineDBAL/Makefile b/databases/pear-DoctrineDBAL/Makefile
new file mode 100644
index 00000000000..77fb01bd4dc
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/Makefile
@@ -0,0 +1,54 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DoctrineDBAL
+PORTVERSION= 2.3.0
+CATEGORIES= databases pear
+MASTER_SITES= http://pear.doctrine-project.org/get/
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Database abstraction layer used to power the ORM package
+
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine
+RUN_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine \
+ ${PEARDIR}/Doctrine/Common/Version.php:${PORTSDIR}/databases/pear-DoctrineCommon \
+ ${PEARDIR}/Symfony/Component/Console/Application.php:${PORTSDIR}/devel/pear-Symfony_Component_Console
+
+OPTIONSFILE?= ${PORT_DBDIR}/pear-${PORTNAME}/options
+OPTIONS_DEFINE= DBLIB MYSQL ODBC PGSQL SQLITE
+OPTIONS_DEFAULT=MYSQL
+
+DBLIB_DESC= Install PHP DBO driver for DBLIB
+MYSQL_DESC= Install PHP DBO driver for MySQL
+ODBC_DESC= Install PHP DBO driver for ODBC
+PGSQL_DESC= Install PHP DBO driver for PostgreSQL
+SQLITE_DESC= Install PHP DBO driver for SQLite
+
+PEAR_CHANNEL= doctrine
+PEAR_AUTOINSTALL= yes
+
+USE_PHP= pdo
+WANT_PHP_CLI= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDBLIB}
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_dblib
+.endif
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= pdo_mysql
+.endif
+.if ${PORT_OPTIONS:MODBC}
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
+.endif
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pdo_pgsql
+.endif
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= pdo_sqlite
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-DoctrineDBAL/distinfo b/databases/pear-DoctrineDBAL/distinfo
new file mode 100644
index 00000000000..4441733e61a
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/DoctrineDBAL-2.3.0.tgz) = 417ea5a3d646ea5400ff29a47a2f38afcf0dcafe149767f85b7fdc61240c419a
+SIZE (PEAR/DoctrineDBAL-2.3.0.tgz) = 143996
diff --git a/databases/pear-DoctrineDBAL/pkg-descr b/databases/pear-DoctrineDBAL/pkg-descr
new file mode 100644
index 00000000000..1504bc74c26
--- /dev/null
+++ b/databases/pear-DoctrineDBAL/pkg-descr
@@ -0,0 +1,4 @@
+The Doctrine DBAL package is the database abstraction layer used to
+power the ORM package.
+
+WWW: http://www.doctrine-project.org/
/+10 * Release maintainership of ports due to personal technical difficulties.naddy2003-07-311-1/+1 * Let be hohest: I really don't have a time now to properly maintain allsobomax2003-07-291-1/+1 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-293-9/+5 * Update xfce4-wm to 3.99.2oliver2003-07-295-1205/+507 * Import the xfce4-rc2 Meta-Portoliver2003-07-296-789/+38 * Add xfce4-systray-3.99.2, an XFce 4 system tray module for xfce4-paneloliver2003-07-295-0/+38 * Add xfce4-panel 3.99.2, xFce 4 panel module.oliver2003-07-295-0/+227 * Add xfce4-desktop 3.99.2,oliver2003-07-295-0/+67 * To prepare the upcomming xfce4 commit, xfce got repo-copied to xfce4oliver2003-07-281-0/+1 * To prepare the upcomming xfce4 commit, xfwm4 has moved to xfce4-wm.oliver2003-07-281-1/+1 * To prepare the upcomming xfce4 commit, xfwm4 has moved to xfce4-wm.oliver2003-07-285-1225/+0 * update x11-wm/windowlab: 1.11 -> 1.12daichi2003-07-223-2/+14 * update x11-wm/9wm: change MASTER_SITESdaichi2003-07-182-4/+1 * Oops, remove empty file.naddy2003-07-181-0/+0 * Update to version 1.2.9naddy2003-07-174-43/+22 * fix x11-wm/flwm:daichi2003-07-161-1/+1 * Remove spager as it depends on sawfish.marcus2003-07-169-112/+0 * Begin the de-orbit burn of the GNOME 1.4 desktop. This is phase I. Allmarcus2003-07-1612-853/+0 * * Use makeinfo --no-split to avoid plist problems [1]marcus2003-07-123-8/+13 * Update to 1.2.8.nork2003-07-126-62/+32 * Update to 0.9.4.adamw2003-07-114-2/+27 * Add multibyte support.cy2003-07-103-0/+15 * update x11-wm/windowlab: 1.10 -> 1.11daichi2003-07-092-2/+2 * update x11-wm/qinx: 0.5 --> 0.6daichi2003-07-072-2/+2 * Update WWW.osa2003-07-071-1/+1 * replace ${PERL} with ${REINPLACE_CMD}oliver2003-07-061-1/+2 * Update 2.5.6 --> 2.5.7cy2003-07-033-3/+10 * Update 2.4.15 --> 2.4.16cy2003-07-034-4/+4 * Update to 1.01arved2003-06-303-9/+7 * Add kwin_flatcurve, a Bluecurve-style window decoration for KDEarved2003-06-275-0/+27 * Maintain-update of x11-wm/pekwmdaichi2003-06-262-24/+13 * update maintainer's email address.leeym2003-06-241-2/+2 * Upgrade to v1.2.2.jkoshy2003-06-214-34/+2 * x11-wm/pekwm to latest version: 0.1.2 --> 0.1.3daichi2003-06-193-30/+57 * Update to 1.1.5.adamw2003-06-192-2/+2 * Quiet compiler warnings on sparc64 by adding missing #includeskris2003-06-162-0/+20 * Remove REINPLACE commands that were rolled into gnomehack.adamw2003-06-123-10/+2 * gpalmer left us a while ago, revert these ports to ports@ MAINTAINER.will2003-06-121-1/+1 * Depends now on x11-wm/sawfish2 instead of x11-wm/sawfish.obraun2003-06-111-6/+2 * Update to 0.9.3.adamw2003-06-112-2/+2 * Add extra MASTER_SITEerwin2003-06-101-1/+2 * Move inclusion of bsd.port.pre.mk later in the file for conditional BROKENkris2003-06-054-23/+23 * Update windowlab 1.09 -> 1.10mich2003-06-042-2/+2 * Add wmDeskGuide-0.1.adamw2003-06-046-0/+65 * Remove after repo-copy to new location.adamw2003-06-0422-414/+0 * Move:adamw2003-06-041-3/+0 * Add fluxbox-devel after repo-copy from fluxbox.adamw2003-06-041-0/+1 * Add fluxbox-devel 0.9.2 after repo-copy from x11-wm/fluxbox.adamw2003-06-047-159/+122 * Add weewm 0.01, a fast and ultra light windowmanager with totalwill2003-06-035-0/+32 * patch to enable compilation with GCC 3.2.2trevor2003-06-012-7/+43 * Fix theme loading on Sparc64.marcus2003-06-012-0/+12 * Update to 2.4.55.marcus2003-05-233-3/+9 * Update to 0.2.4, and unmark BROKEN for 5.X.adamw2003-05-232-12/+12 * Remove obsolete (and broken) kde-icontheme-crystal.olgeni2003-05-225-1839/+0 * I haven't reviewed the sources for the new versions.trevor2003-05-222-0/+4 * Update to 2.2.3ade2003-05-218-84/+331 * Remove unnecessary BUILD_DEPENDS and clean up the Makefile a bit.adamw2003-05-211-12/+8 * Add a patch to prevent lockups with custom menus.marcus2003-05-212-1/+13 * Mark ONLY_FOR_ARCHS=i386.adamw2003-05-202-8/+69 * Update to KDE 3.1.2lioux2003-05-207-119/+374 * Fix build on -CURRENT.adamw2003-05-202-5/+21 * Update to 1.0.24.petef2003-05-192-2/+2 * BROKEN on 5.1: bad C++kris2003-05-181-1/+7 * BROKEN on 5.1: bad C++kris2003-05-181-1/+7 * BROKEN on 5.1: fails to linkkris2003-05-182-2/+14 * BROKEN on 5.1: bad C++kris2003-05-182-2/+14 * BROKEN on 5.1: bad C++kris2003-05-181-1/+7 * BROKEN on 5.1: does not compilekris2003-05-181-1/+7 * Add xfwm4 020724, gtk-2.0 based window manager part of the XFCEpetef2003-05-1211-0/+2451 * Unbreak by depending on gtk20arved2003-05-101-3/+1 * BROKEN: Does not compilekris2003-05-071-0/+2 * BROKEN: Does not linkkris2003-05-061-0/+2 * Update PORTREVISION encompassing last two commits.cy2003-05-051-0/+1 * Fix for failure to detect fontconfig >= 2.1.92.cy2003-05-051-4/+45 * Fix broken dependency.cy2003-05-051-1/+1 * Chase guile's shared lib version.marcus2003-05-021-1/+1 * Upgrade to 0.99.14.sumikawa2003-05-022-6/+6 * I missed the previously defined configure args. Add --with-esd to thosemarcus2003-04-271-2/+2 * - Add two patches I forgot to commit in the previous commitingsumikawa2003-04-274-11/+50 * Make esound support permanent since esound must be installed to installmarcus2003-04-271-12/+4 * 1. Fix build error reported by Bento.cy2003-04-241-0/+7 * Convert to new GNOME infrastructure.marcus2003-04-222-9/+3 * Install files mode 644, not 664kris2003-04-214-12/+32 * Upgrade to 1.2.7sumikawa2003-04-2117-326/+124 * USE_IMLIB is deprecated. Switching all USE_IMLIB references to appropriateadamw2003-04-211-1/+1 * Add windowlab.adamw2003-04-215-0/+45 * Remove USE_GNOMENG.marcus2003-04-2128-28/+0 * [patch] x11-wm/9menu rechange url in Makefileedwin2003-04-181-1/+1 * [MAINTAINER UPDATE] x11-wm/oroborus to 2.0.12edwin2003-04-133-4/+39 * x11-wm/9menu change MASTER_SITESedwin2003-04-131-1/+1 * Add Xft dependency when WITH_XFT is defined.nork2003-04-122-2/+4 * o fix crash on sticky windows if compiled with Remember patchnork2003-04-126-6/+44 * Enable compilation with GCC 3 (tested with 3.2.2).trevor2003-04-091-0/+11 * Install man page.trevor2003-04-091-0/+2 * Update to 0.12.40.trevor2003-04-092-6/+4 * Rejoice, for the long awaited upgrade to kde 3.1.1 is here!alane2003-04-062-1/+2 * Add missing info fileskris2003-04-061-0/+2 * Update to 1.3.marcus2003-04-044-37/+21 * Udate 2.5.5 -> 2.5.6.cy2003-04-043-4/+7 * Update to 1.6.adamw2003-04-023-9/+9 * Chase new website in MASTER_SITES and WWW.adamw2003-03-232-2/+2 * Clear moonlight beckons.ade2003-03-0774-37/+37 * Update to 0.5arved2003-03-052-2/+2 * Add "portuguese" category.trevor2003-03-011-1/+1 * Retire comment file.trevor2003-03-0128-14/+14 * Use pre-everything:: instead of pre-everything: to avoid conflict withkris2003-03-013-3/+3 * New port: wampager -- a mini pager for waimea window managerfjoe2003-02-276-0/+51 * Change URL to the projects Sourceforge site.marcus2003-02-261-1/+1 * De-pkg-comment.marcus2003-02-262-1/+1 * maintainer-update: x11-wm/fbdesk to 1.1.3.edwin2003-02-242-2/+2 * De-pkg-comment my ports + some more.olgeni2003-02-232-1/+1 * De-pkg-comment.bmah2003-02-232-1/+1 * Update 2.4.14 --> 2.4.15cy2003-02-234-4/+4 * De-pkg-comment.matusita2003-02-222-1/+1 * De-pkg-comment.knu2003-02-2158-29/+29 * De-pkg-comment.knu2003-02-21