aboutsummaryrefslogtreecommitdiffstats
path: root/databases/php5-pdo_oci
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-02-09 16:41:26 +0800
committerale <ale@FreeBSD.org>2007-02-09 16:41:26 +0800
commitcf5593215e0d258f2973759b0bdd825968c41dd0 (patch)
tree560a61478b56dfb63979086977015975c670d5f0 /databases/php5-pdo_oci
parentafdb949e6cc5c24d18e1d17fede50246211419f5 (diff)
downloadfreebsd-ports-graphics-cf5593215e0d258f2973759b0bdd825968c41dd0.tar.gz
freebsd-ports-graphics-cf5593215e0d258f2973759b0bdd825968c41dd0.tar.zst
freebsd-ports-graphics-cf5593215e0d258f2973759b0bdd825968c41dd0.zip
Add PDO oci driver.
Diffstat (limited to 'databases/php5-pdo_oci')
-rw-r--r--databases/php5-pdo_oci/Makefile14
-rw-r--r--databases/php5-pdo_oci/files/patch-config.m419
2 files changed, 33 insertions, 0 deletions
diff --git a/databases/php5-pdo_oci/Makefile b/databases/php5-pdo_oci/Makefile
new file mode 100644
index 00000000000..c65accb5656
--- /dev/null
+++ b/databases/php5-pdo_oci/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php5-pdo_oci
+# Date created: 7 Feb 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php5
+
+PKGNAMESUFFIX= -pdo_oci
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php5-pdo_oci/files/patch-config.m4 b/databases/php5-pdo_oci/files/patch-config.m4
new file mode 100644
index 00000000000..bcc94e0961e
--- /dev/null
+++ b/databases/php5-pdo_oci/files/patch-config.m4
@@ -0,0 +1,19 @@
+--- config.m4.orig Thu Feb 16 03:03:13 2006
++++ config.m4 Wed Feb 7 15:00:58 2007
+@@ -145,7 +145,6 @@
+ ;;
+
+ 8.1)
+- PHP_ADD_LIBRARY(clntsh, 1, PDO_OCI_SHARED_LIBADD)
+ ;;
+
+ 9.0)
+@@ -163,7 +162,7 @@
+ ;;
+ esac
+
+- PHP_ADD_LIBPATH($PDO_OCI_LIB_DIR, PDO_OCI_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(oci8, ., PDO_OCI_SHARED_LIBADD)
+
+ PHP_CHECK_LIBRARY(clntsh, OCIEnvCreate,
+ [