aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-devel-server/Makefile
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-12-06 05:22:42 +0800
committerseanc <seanc@FreeBSD.org>2003-12-06 05:22:42 +0800
commite7457cad93ff676ca93786eaf21a605991709083 (patch)
tree8601c08bc60dfd951c3bc85906027ed48a302215 /databases/postgresql-devel-server/Makefile
parent8ffd11e954fd10ae3c2d4e1b8674568fa729aacb (diff)
downloadfreebsd-ports-graphics-e7457cad93ff676ca93786eaf21a605991709083.tar.gz
freebsd-ports-graphics-e7457cad93ff676ca93786eaf21a605991709083.tar.zst
freebsd-ports-graphics-e7457cad93ff676ca93786eaf21a605991709083.zip
Remove the PORTNAME from postgreql-client. PORTNAME is set by
MASTERDIR/Makefile[1]. Improve the CONFLICTS messages[2]. Fix the DEPENDS so that MIT krb5 depends on security/krb5, not heimdal[3]. Add a file that was missing in the upgrade that has PostgreSQL log to syslog by default[4]. PR: [4] Originally submitted in ports/59402 Submitted by: [1,2,4] maintainer [3] keoki seu <keoki@camelot.physics.wm.edu>
Diffstat (limited to 'databases/postgresql-devel-server/Makefile')
-rw-r--r--databases/postgresql-devel-server/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/postgresql-devel-server/Makefile b/databases/postgresql-devel-server/Makefile
index 9192a2f1d16..4f17a17f902 100644
--- a/databases/postgresql-devel-server/Makefile
+++ b/databases/postgresql-devel-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif