aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-libpqxx
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-06-25 02:45:32 +0800
committerthierry <thierry@FreeBSD.org>2004-06-25 02:45:32 +0800
commit942f0c04a197be500bc169cada35fc609ee1acb3 (patch)
treebe24ed43dace866ffa9872a209ce3ad2fbce1240 /databases/postgresql-libpqxx
parent2bb3d501815dab8a21a769827c581e53e278123f (diff)
downloadfreebsd-ports-graphics-942f0c04a197be500bc169cada35fc609ee1acb3.tar.gz
freebsd-ports-graphics-942f0c04a197be500bc169cada35fc609ee1acb3.tar.zst
freebsd-ports-graphics-942f0c04a197be500bc169cada35fc609ee1acb3.zip
Unbreak on -STABLE.
PR: ports/68217 Submitted by: maintainer.
Diffstat (limited to 'databases/postgresql-libpqxx')
-rw-r--r--databases/postgresql-libpqxx/Makefile9
-rw-r--r--databases/postgresql-libpqxx/pkg-plist2
2 files changed, 8 insertions, 3 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 356e3870f21..506ae6fb1a4 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -21,6 +21,7 @@ USE_LIBTOOL_VER=15
USE_GMAKE= YES
GNU_CONFIGURE= YES
INSTALLS_SHLIB= YES
+PLIST_SUB= PORTVERSION=${PORTVERSION}
CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
--enable-shared \
@@ -30,8 +31,12 @@ POSTGRESQL_PORT?= databases/postgresql7
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "<ios> header missing on this platform"
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CXXFLAGS+= -I${LOCALBASE}/include/stlport
+LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
.include <bsd.port.post.mk>
diff --git a/databases/postgresql-libpqxx/pkg-plist b/databases/postgresql-libpqxx/pkg-plist
index 891965a7093..4ead0353164 100644
--- a/databases/postgresql-libpqxx/pkg-plist
+++ b/databases/postgresql-libpqxx/pkg-plist
@@ -67,7 +67,7 @@ include/pqxx/util.h
lib/libpqxx.a
lib/libpqxx.la
lib/libpqxx.so
-lib/libpqxx-2.2.3.so
+lib/libpqxx-%%PORTVERSION%%.so
lib/libdata/pkgconfig/libpqxx.pc
@dirrm include/pqxx
@unexec rmdir %D/lib/libdata/pkgconfig 2>/dev/null || true