aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-MySQLdb
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-09-10 15:52:20 +0800
committersobomax <sobomax@FreeBSD.org>2002-09-10 15:52:20 +0800
commitd069f4753ca36e561432e28f991f299a773d43b6 (patch)
treeecc7ef48281cbec9a927e272b086b79ca5b29bab /databases/py-MySQLdb
parentf7f4203f704935cfb484ec61d5910fac0c274231 (diff)
downloadfreebsd-ports-graphics-d069f4753ca36e561432e28f991f299a773d43b6.tar.gz
freebsd-ports-graphics-d069f4753ca36e561432e28f991f299a773d43b6.tar.zst
freebsd-ports-graphics-d069f4753ca36e561432e28f991f299a773d43b6.zip
Update to 0.9.2.
Diffstat (limited to 'databases/py-MySQLdb')
-rw-r--r--databases/py-MySQLdb/Makefile5
-rw-r--r--databases/py-MySQLdb/distinfo2
-rw-r--r--databases/py-MySQLdb/files/patch-ab38
3 files changed, 25 insertions, 20 deletions
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index 1fc5cd04a46..50a1c052e34 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= py-MySQLdb
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.2
CATEGORIES= databases python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mysql-python
@@ -21,9 +21,6 @@ USE_PYDISTUTILS= yes
DOCS= MANIFEST README doc/*.html
-do-configure:
- @${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/databases/py-MySQLdb/distinfo b/databases/py-MySQLdb/distinfo
index 21818138a9d..8728dca4b0c 100644
--- a/databases/py-MySQLdb/distinfo
+++ b/databases/py-MySQLdb/distinfo
@@ -1 +1 @@
-MD5 (MySQL-python-0.9.1.tar.gz) = 802e271d46e3d845045ce0378f82fd85
+MD5 (MySQL-python-0.9.2.tar.gz) = afef758f56289f98408dd9f379d8fc8d
diff --git a/databases/py-MySQLdb/files/patch-ab b/databases/py-MySQLdb/files/patch-ab
index f468651029c..43239f23b4a 100644
--- a/databases/py-MySQLdb/files/patch-ab
+++ b/databases/py-MySQLdb/files/patch-ab
@@ -1,15 +1,23 @@
---- setup.py.orig Wed Oct 17 05:17:30 2001
-+++ setup.py Tue Jan 22 00:33:59 2002
-@@ -24,9 +24,9 @@
- libraries = [mysqlclient, "z"]
- runtime_library_dirs = []
- extra_objects = []
--elif sys.platform in ("freebsd4", "openbsd2"):
-- include_dirs = ['/usr/local/include/mysql']
-- library_dirs = ['/usr/local/lib/mysql']
-+elif sys.platform[:7] in ("freebsd", "openbsd"):
-+ include_dirs = ['%%LOCALBASE%%/include/mysql']
-+ library_dirs = ['%%LOCALBASE%%/lib/mysql']
- libraries = [mysqlclient, "z"]
- runtime_library_dirs = []
- extra_objects = []
+
+$FreeBSD$
+
+--- setup.py.orig Thu Jul 18 22:55:36 2002
++++ setup.py Tue Sep 10 10:51:52 2002
+@@ -11,7 +11,7 @@
+ NO = 0
+
+ # set this to YES if you have the thread-safe mysqlclient library
+-thread_safe_library = YES
++thread_safe_library = NO
+
+ # You probably don't have to do anything past this point. If you
+ # do, please mail me the configuration for your platform. Don't
+@@ -51,7 +51,7 @@
+ if sys.platform == "netbsd1":
+ include_dirs = ['/usr/pkg/include/mysql']
+ library_dirs = ['/usr/pkg/lib/mysql']
+-elif sys.platform in ("freebsd4", "openbsd3"):
++elif sys.platform[:7] in ("freebsd", "openbsd"):
+ LOCALBASE = os.environ.get('LOCALBASE', '/usr/local')
+ include_dirs = ['%s/include/mysql' % LOCALBASE]
+ library_dirs = ['%s/lib/mysql' % LOCALBASE]