aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-pyPgSQL/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-10 12:18:06 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-10 12:18:06 +0800
commit09af3e5f7c0e5330077b4132950fba338f385e67 (patch)
tree77263f8aed85fa2a9bf13bf278019cae8e1f0dec /databases/py-pyPgSQL/Makefile
parentc32e2ca82ed1d366663046365e3ea4ad8e4f71e0 (diff)
downloadfreebsd-ports-graphics-09af3e5f7c0e5330077b4132950fba338f385e67.tar.gz
freebsd-ports-graphics-09af3e5f7c0e5330077b4132950fba338f385e67.tar.zst
freebsd-ports-graphics-09af3e5f7c0e5330077b4132950fba338f385e67.zip
PostgreSQL 8.3.1 has changed it's bytea encoding.
* in PostgreSQL 8.3.1 Release note Make encode(bytea, 'escape') convert all high-bit-set byte values into \nnn octal escape sequences (Tom) This is necessary to avoid encoding problems when the database encoding is multi-byte. This change could pose compatibility issues for applications that are expecting specific results from encode. but pyPgSQL escape bytea encode as it's own implementments. PostgreSQL says that it may make failure(see PQescapeBytea documentation). in PQescapeBytea function documentation: "The only difference from PQescapeByteaConn is that PQescapeBytea does not take a PGconn parameter. Because of this, it cannot adjust its behavior depending on the connection properties (in particular, whether standard-conforming strings are enabled) and therefore it might give the wrong results. Also, it has no way to return an error message on failure." Patch is included upstream already PR: ports/122616 Submitted by: "Choe, Cheng-Dae" <whitekid@gmail.com>
Diffstat (limited to 'databases/py-pyPgSQL/Makefile')
-rw-r--r--databases/py-pyPgSQL/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/databases/py-pyPgSQL/Makefile b/databases/py-pyPgSQL/Makefile
index dc7895604a7..3c52ebd6178 100644
--- a/databases/py-pyPgSQL/Makefile
+++ b/databases/py-pyPgSQL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pyPgSQL
PORTVERSION= 2.5.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -26,6 +26,16 @@ EXAMPLES= examples/*.py
DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
+OPTIONS= BYTEA_CONN "Apply Bytea connection patch" On
+
+# bypass infrastructure bug
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.if !defined(WITH_BYTEA_CONN)
+PATCH_SITES= http://sourceforge.net/tracker/download.php?group_id=16528&atid=316528&file_id=273956&aid=1939119/
+PATCHFILES= pyPgSQL-patch_byteaconn
+.endif
+
DOCSDIR= ${PREFIX}/share/doc/py-pyPgSQL
EXAMPLESDIR= ${PREFIX}/share/examples/py-pyPgSQL