aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-sqlobject/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-02 07:11:04 +0800
committerpav <pav@FreeBSD.org>2004-07-02 07:11:04 +0800
commit5d0dc8f3ba95d7310d37faf6120172cd6a27b107 (patch)
tree603e0fba0fb63b939c59db40827bbd3824f5a7b0 /databases/py-sqlobject/Makefile
parenta5b6456fecf3ef9315accbf4a023ca0bcadf5516 (diff)
downloadfreebsd-ports-graphics-5d0dc8f3ba95d7310d37faf6120172cd6a27b107.tar.gz
freebsd-ports-graphics-5d0dc8f3ba95d7310d37faf6120172cd6a27b107.tar.zst
freebsd-ports-graphics-5d0dc8f3ba95d7310d37faf6120172cd6a27b107.zip
Add py-sqlobject, a Python class that allows you to translate RDBMS table rows
into Python objects, and manipulate those objects to transparently manipulate the database. PR: ports/68501 Submitted by: Choe, Cheng-Dae <whitekid@netian.com>
Diffstat (limited to 'databases/py-sqlobject/Makefile')
-rw-r--r--databases/py-sqlobject/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/py-sqlobject/Makefile b/databases/py-sqlobject/Makefile
new file mode 100644
index 00000000000..7f8b6a4a5ec
--- /dev/null
+++ b/databases/py-sqlobject/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: py-sqlobject
+# Date created: 24 June 2004
+# Whom: "Choe, Cheng-Dae" whitekid
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlobject
+PORTVERSION= 0.5.2
+CATEGORIES= databases python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= SQLObject-${PORTVERSION}
+
+MAINTAINER= whitekid@netian.com
+COMMENT= A python object for manipulation with SQL table row
+
+# Someone will add SQLite, Firebird and DBMConnection support things.
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb \
+ ${PYTHON_SITELIBDIR}/psycopgmodule.so:${PORTSDIR}/databases/py-psycopg
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>