aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ruby-mysql
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-01-29 18:08:06 +0800
committerknu <knu@FreeBSD.org>2003-01-29 18:08:06 +0800
commite3eef3e7a04a50851ab1db37c80b9bfe22046ee2 (patch)
tree7595450f98b3c5a65e6fd4d54f6fe53dce818f38 /databases/ruby-mysql
parent837af1586b69486311d0ab94dcf130d199709bc0 (diff)
downloadfreebsd-ports-graphics-e3eef3e7a04a50851ab1db37c80b9bfe22046ee2.tar.gz
freebsd-ports-graphics-e3eef3e7a04a50851ab1db37c80b9bfe22046ee2.tar.zst
freebsd-ports-graphics-e3eef3e7a04a50851ab1db37c80b9bfe22046ee2.zip
Update to 2.4.4 and add a patch to make it build with ruby 1.8.
Diffstat (limited to 'databases/ruby-mysql')
-rw-r--r--databases/ruby-mysql/Makefile2
-rw-r--r--databases/ruby-mysql/distinfo2
-rw-r--r--databases/ruby-mysql/files/patch-extconf.rb22
3 files changed, 24 insertions, 2 deletions
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
index 892be840f58..5b9267501b3 100644
--- a/databases/ruby-mysql/Makefile
+++ b/databases/ruby-mysql/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mysql
-PORTVERSION= 2.4.3b
+PORTVERSION= 2.4.4
CATEGORIES= databases ruby
MASTER_SITES= http://www.tmtm.org/mysql/ruby/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/databases/ruby-mysql/distinfo b/databases/ruby-mysql/distinfo
index 18ce093d215..42ee5d55a65 100644
--- a/databases/ruby-mysql/distinfo
+++ b/databases/ruby-mysql/distinfo
@@ -1 +1 @@
-MD5 (ruby/mysql-ruby-2.4.3b.tar.gz) = 61f7b1d9bd4ff840769d545392fe0d0a
+MD5 (ruby/mysql-ruby-2.4.4.tar.gz) = 51e99fc005d1f9b94fd1881bd307383a
diff --git a/databases/ruby-mysql/files/patch-extconf.rb b/databases/ruby-mysql/files/patch-extconf.rb
new file mode 100644
index 00000000000..529f22b65b2
--- /dev/null
+++ b/databases/ruby-mysql/files/patch-extconf.rb
@@ -0,0 +1,22 @@
+--- extconf.rb.orig Wed Jan 29 08:59:59 2003
++++ extconf.rb Wed Jan 29 19:02:41 2003
+@@ -24,13 +24,18 @@
+ else
+ exit 1
+ end
++$objs = ["mysql.o"]
+ create_makefile("mysql")
+
+ # make mysql constant
+ File::open("conftest.c", "w") do |f|
+ f.puts src
+ end
+-cpp = Config::expand sprintf(CPP, $CPPFLAGS, $CFLAGS, '')
++if defined? cpp_command
++ cpp = Config.expand(cpp_command(CONFIG['CPPOUTFILE']))
++else
++ cpp = Config::expand sprintf(CPP, $CPPFLAGS, $CFLAGS, '')
++end
+ unless system "#{cpp} > confout" then
+ exit 1
+ end