aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ruby-mysql
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /databases/ruby-mysql
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'databases/ruby-mysql')
-rw-r--r--databases/ruby-mysql/Makefile18
-rw-r--r--databases/ruby-mysql/pkg-descr1
-rw-r--r--databases/ruby-mysql/pkg-plist2
3 files changed, 11 insertions, 10 deletions
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
index 5dcff66b2e3..2c3a6a1bb40 100644
--- a/databases/ruby-mysql/Makefile
+++ b/databases/ruby-mysql/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: Ruby-MySQL
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+# New ports collection makefile for: Ruby-MySQL
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
@@ -19,19 +19,19 @@ BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+INSTALL_TARGET= site-install
+
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
-do-install:
- @cd ${WRKSRC}; \
- ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET}
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/mysql/ja
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/mysql/
diff --git a/databases/ruby-mysql/pkg-descr b/databases/ruby-mysql/pkg-descr
index 189a24aa6b3..37fa1e8b836 100644
--- a/databases/ruby-mysql/pkg-descr
+++ b/databases/ruby-mysql/pkg-descr
@@ -1,4 +1,5 @@
This is a Ruby module for accessing MySQL databases, which has the
same functions as C API.
+Author: TOMITA Masahiro <tommy@tmtm.org>
WWW: http://www.tmtm.org/mysql/ruby/README
diff --git a/databases/ruby-mysql/pkg-plist b/databases/ruby-mysql/pkg-plist
index 63cb1ac4de4..b62f12b041a 100644
--- a/databases/ruby-mysql/pkg-plist
+++ b/databases/ruby-mysql/pkg-plist
@@ -1,4 +1,4 @@
-lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/mysql.so
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/mysql.so
share/doc/ruby/mysql/ja/README.jp
share/doc/ruby/mysql/README
@dirrm share/doc/ruby/mysql/ja