aboutsummaryrefslogtreecommitdiffstats
path: root/databases/sqlrelay
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
committergirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
commitca9d0e2291f677879c1b36a416eb2ad271850cbc (patch)
tree339f4530a6f0b38252173ddc8ba47c21226501d3 /databases/sqlrelay
parentcbe074a01a678ad3149123153f48962b4b035576 (diff)
downloadfreebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.gz
freebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.zst
freebsd-ports-graphics-ca9d0e2291f677879c1b36a416eb2ad271850cbc.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Diffstat (limited to 'databases/sqlrelay')
-rw-r--r--databases/sqlrelay/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/databases/sqlrelay/Makefile b/databases/sqlrelay/Makefile
index 4c86b9e5f03..b41525043f4 100644
--- a/databases/sqlrelay/Makefile
+++ b/databases/sqlrelay/Makefile
@@ -34,8 +34,6 @@ CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-POSTGRESQL_PORT?= databases/postgresql7
-
.include "${.CURDIR}/Makefile.common"
OPTIONS= MSQL "Build MSQL connection" off \
@@ -89,7 +87,7 @@ IF_MSQL= "@comment "
.endif
.if defined(WITH_POSTGRESQL) && ${WITH_POSTGRESQL:L} != no
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql-prefix="${LOCALBASE}"
IF_POSTGRESQL= ""
.else