aboutsummaryrefslogtreecommitdiffstats
path: root/databases/virtuoso/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2016-10-05 03:41:37 +0800
committerfjoe <fjoe@FreeBSD.org>2016-10-05 03:41:37 +0800
commit374fdd97b51df3b2f68a01513fc450c140d78333 (patch)
tree6afa7649009dac9c7d0d260c62b05906f8efc684 /databases/virtuoso/Makefile
parentfcf25bb7c953a9d4b5a33ae2885d8c2f66a02a1d (diff)
downloadfreebsd-ports-graphics-374fdd97b51df3b2f68a01513fc450c140d78333.tar.gz
freebsd-ports-graphics-374fdd97b51df3b2f68a01513fc450c140d78333.tar.zst
freebsd-ports-graphics-374fdd97b51df3b2f68a01513fc450c140d78333.zip
- Update to 7.2.4.2
- Fix ownership of installed files
Diffstat (limited to 'databases/virtuoso/Makefile')
-rw-r--r--databases/virtuoso/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 88a492d8a0a..6942f95cb70 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= virtuoso
-PORTVERSION= 7.1.0
-PORTREVISION= 5
+PORTVERSION= 7.2.4.2
+PORTREVISION= 0
CATEGORIES= databases
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-opensource-${PORTVERSION}
@@ -20,7 +20,8 @@ BUILD_DEPENDS= gawk:lang/gawk\
htmldoc:textproc/htmldoc\
flex>2.5.4:textproc/flex\
gperf>=3.0.3:devel/gperf
-LIB_DEPENDS= libxml2.so:textproc/libxml2
+LIB_DEPENDS= libxml2.so:textproc/libxml2\
+ libexecinfo.so:devel/libexecinfo
USES= gmake libtool readline uidfix
USE_AUTOTOOLS= autoheader aclocal
@@ -41,7 +42,7 @@ CONFIGURE_ARGS= --with-readline\
--datadir="${PREFIX}"\
--localstatedir="${PREFIX}"
CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}\
ISQL=isql-vt
USE_RC_SUBR= virtuoso