aboutsummaryrefslogtreecommitdiffstats
path: root/databases/xmysql
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1997-09-02 22:56:45 +0800
committerandreas <andreas@FreeBSD.org>1997-09-02 22:56:45 +0800
commit3604148351e6b02f8a7f5fd71aa7ca51d49dc2c1 (patch)
treed06ec33661114c2bbd1b2c6519b1cec6480bc6b2 /databases/xmysql
parent6baf77f72dfae973930765b7ede835f0cb66a7ed (diff)
downloadfreebsd-ports-graphics-3604148351e6b02f8a7f5fd71aa7ca51d49dc2c1.tar.gz
freebsd-ports-graphics-3604148351e6b02f8a7f5fd71aa7ca51d49dc2c1.tar.zst
freebsd-ports-graphics-3604148351e6b02f8a7f5fd71aa7ca51d49dc2c1.zip
New port xmysql.
XmySQL is a front end to the MySQL database engine. It allows for simple queries and table maintenance, as well as batch queries. XmySQL has been compiled and tested on Linux 2.0.0 with MySQL 3.20.16 and Xforms version 0.86.
Diffstat (limited to 'databases/xmysql')
-rw-r--r--databases/xmysql/Makefile25
-rw-r--r--databases/xmysql/distinfo1
-rw-r--r--databases/xmysql/files/patch-aa68
-rw-r--r--databases/xmysql/files/patch-ab14
-rw-r--r--databases/xmysql/pkg-comment1
-rw-r--r--databases/xmysql/pkg-descr9
-rw-r--r--databases/xmysql/pkg-plist4
7 files changed, 122 insertions, 0 deletions
diff --git a/databases/xmysql/Makefile b/databases/xmysql/Makefile
new file mode 100644
index 00000000000..58a5c9e40fa
--- /dev/null
+++ b/databases/xmysql/Makefile
@@ -0,0 +1,25 @@
+# ports collection makefile for: xmysql
+# Version required: 1.5
+# Date created: Tue Sep 2 15:46:09 CEST 1997
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id$
+#
+
+DISTNAME= xmysql-1.5
+CATEGORIES= databases
+MASTER_SITES= ftp://mysql.staufen.de/pub/mysql/Contrib/ \
+ http://www.tcx.se/Contrib/ \
+ http://www.buoy.com/mysql/Contrib/ \
+ http://web.tryc.on.ca/mysql/Contrib/ \
+ http://mysql.acer.net/Contrib/
+
+MAINTAINER= andreas@FreeBSD.ORG
+
+BUILD_DEPENDS= mysql:${PORTSDIR}/databases/mysql
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm \
+ xforms\\.0\\.:${PORTSDIR}/x11/xforms
+
+USE_X11= yes
+
+.include <bsd.port.mk>
diff --git a/databases/xmysql/distinfo b/databases/xmysql/distinfo
new file mode 100644
index 00000000000..5cc17c278cf
--- /dev/null
+++ b/databases/xmysql/distinfo
@@ -0,0 +1 @@
+MD5 (xmysql-1.5.tar.gz) = 6cf412e86d89b98dfc084b75fb8956c7
diff --git a/databases/xmysql/files/patch-aa b/databases/xmysql/files/patch-aa
new file mode 100644
index 00000000000..9155b63f3fb
--- /dev/null
+++ b/databases/xmysql/files/patch-aa
@@ -0,0 +1,68 @@
+--- Makefile.orig Mon May 12 20:19:36 1997
++++ Makefile Tue Sep 2 16:26:44 1997
+@@ -1,5 +1,5 @@
+ #
+-# Makefile for XmySQL on Linux
++# Makefile for XmySQL on FreeBSD
+ #
+
+ ########################################################
+@@ -36,24 +36,24 @@
+ PROGRAM = xmysql
+
+ # PROGRAM install path
+-INSTALLPATH = /xmysql-1.4
++INSTALLPATH = $(X11BASE)/bin
+
+ # pixmap location
+-XPM_PATH = /xmysql-1.4
++XPM_PATH = $(X11BASE)/include/X11/pixmaps
+
+ # help path
+-HELP_PATH = /xmysql-1.4
++HELP_PATH = $(X11BASE)/lib/X11/xmysql-1.5
+
+ # Compilation Details
+-CC = gcc
+-STDCFLAGS = -g -c -O2 -Wall -DXPMPATH=\"$(XPM_PATH)\" -DHELPPATH=\"$(HELP_PATH)\"
++# CC = gcc
++STDCFLAGS = $(CFLAGS) -c -DXPMPATH=\"$(XPM_PATH)\" -DHELPPATH=\"$(HELP_PATH)\"
+ STDLFLAGS =
+ MYSQLINC = -I/usr/local/include/mysql
+ MYSQLLOAD = -L/usr/local/lib/mysql -lmysqlclient -lmysys -ldbug -lmystrings
+-XFORMLIBDIR = -L/usr/lib
+-XFORMINCDIR = -I/usr/include
++XFORMLIBDIR = -L$(X11BASE)/lib
++XFORMINCDIR = -I$(X11BASE)/include
+ XINC =
+-XLOAD = -L/usr/X11R6/lib -lX11
++XLOAD = -L$(X11BASE)/lib -lX11
+
+ # objects needed for the program
+ OBJS = Xmysql.o \
+@@ -62,10 +62,12 @@
+ XmysqlDB.o \
+ XmysqlErr.o
+
++all: ${PROGRAM}
++
+ ${PROGRAM}: $(OBJS)
+ $(CC) -o ${PROGRAM} $(OBJS) $(MYSQLINC) $(XFORMINCDIR) \
+ $(XINC) $(STDLFLAGS) $(MYSQLLOAD) \
+- $(XLOAD) $(XFORMLIBDIR) -lforms -lXpm -lm
++ $(XLOAD) $(XFORMLIBDIR) -lxforms -lXpm -lm
+
+ .c.o:
+ $(CC) $*.c $(STDCFLAGS) $(XFORMINCDIR) $(MYSQLINC) $(XINC)
+@@ -74,7 +76,7 @@
+ rm -f ${PROGRAM} $(OBJS)
+
+ install:
+- install --mode=711 $(PROGRAM) $(INSTALLPATH)
+- install --mode=744 mysql.xpm $(XPM_PATH)
+- install --mode=744 sqlhelp.txt $(HELP_PATH)
+-
++ install -s -m 511 $(PROGRAM) $(INSTALLPATH)
++ install -m 444 mysql.xpm $(XPM_PATH)
++ install -d -m 755 $(HELP_PATH)
++ install -m 444 sqlhelp.txt $(HELP_PATH)
diff --git a/databases/xmysql/files/patch-ab b/databases/xmysql/files/patch-ab
new file mode 100644
index 00000000000..99a6bafccca
--- /dev/null
+++ b/databases/xmysql/files/patch-ab
@@ -0,0 +1,14 @@
+--- Xmysql_cb.c.orig Tue Sep 2 16:08:23 1997
++++ Xmysql_cb.c Tue Sep 2 16:09:08 1997
+@@ -1,5 +1,11 @@
+ #include <string.h>
++
++#ifdef __FreeBSD__
++#include <stdlib.h>
++#else
+ #include <malloc.h>
++#endif
++
+ #include "forms.h"
+ #include "Xmysql.h"
+ #include "XmysqlDB.h"
diff --git a/databases/xmysql/pkg-comment b/databases/xmysql/pkg-comment
new file mode 100644
index 00000000000..7434e507535
--- /dev/null
+++ b/databases/xmysql/pkg-comment
@@ -0,0 +1 @@
+X11 front end to the MySQL database engine
diff --git a/databases/xmysql/pkg-descr b/databases/xmysql/pkg-descr
new file mode 100644
index 00000000000..5a8b2255109
--- /dev/null
+++ b/databases/xmysql/pkg-descr
@@ -0,0 +1,9 @@
+XmySQL is a front end to the MySQL database engine. It allows for
+simple queries and table maintenance, as well as batch queries.
+XmySQL has been compiled and tested on Linux 2.0.0 with MySQL 3.20.16
+and Xforms version 0.86.
+
+Rick Mehalick
+dblhack@wt.net
+rmehalic@i-o.com
+http://web.wt.net/~dblhack
diff --git a/databases/xmysql/pkg-plist b/databases/xmysql/pkg-plist
new file mode 100644
index 00000000000..e4fd997802e
--- /dev/null
+++ b/databases/xmysql/pkg-plist
@@ -0,0 +1,4 @@
+bin/xmysql
+include/X11/pixmaps/mysql.xpm
+lib/X11/xmysql-1.5/sqlhelp.txt
+@dirrm lib/X11/xmysql-1.5