aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-28 19:06:43 +0800
committerpav <pav@FreeBSD.org>2004-02-28 19:06:43 +0800
commit028f3f77d1f7df56e6a35620c22b1dc34d574962 (patch)
tree7fda1e509984d6700ced2040aa982f86f0b42b43 /databases
parent3001d6e5fb62330fd16914899801791570576c82 (diff)
downloadfreebsd-ports-graphics-028f3f77d1f7df56e6a35620c22b1dc34d574962.tar.gz
freebsd-ports-graphics-028f3f77d1f7df56e6a35620c22b1dc34d574962.tar.zst
freebsd-ports-graphics-028f3f77d1f7df56e6a35620c22b1dc34d574962.zip
Add pear-DB_Pager, a class handles all the stuff needed for displaying
paginated results from a database query of Pear DB. including fetching only the needed rows and giving extensive information for helping build an HTML or GTK query result display. PR: ports/63346 Submitted by: Toshiya SAITOH <toshiya@saitoh.nu>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-DB_Pager/Makefile25
-rw-r--r--databases/pear-DB_Pager/distinfo2
-rw-r--r--databases/pear-DB_Pager/pkg-descr8
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 39c5dd511dc..344bd60717e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -177,6 +177,7 @@
SUBDIR += p5-postgresql-plperl
SUBDIR += p5-sqlrelay
SUBDIR += pear-DB
+ SUBDIR += pear-DB_Pager
SUBDIR += pgaccess
SUBDIR += pgadmin3
SUBDIR += pgbash
diff --git a/databases/pear-DB_Pager/Makefile b/databases/pear-DB_Pager/Makefile
new file mode 100644
index 00000000000..ed573b7b8a4
--- /dev/null
+++ b/databases/pear-DB_Pager/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-DB_Pager
+# Date created: 25 Febrary 2004
+# Whom: Toshiya Saitoh (<toshiya@saitoh.nu>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= DB_Pager
+PORTVERSION= 0.7
+CATEGORIES= databases www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= toshiya@saitoh.nu
+COMMENT= PEAR Database Abstraction Layer
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR \
+ ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+FILES= Pager.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_Pager/distinfo b/databases/pear-DB_Pager/distinfo
new file mode 100644
index 00000000000..d7d724187f2
--- /dev/null
+++ b/databases/pear-DB_Pager/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/DB_Pager-0.7.tgz) = ec4213fe39bdfab951b14433a6ae60c0
+SIZE (PEAR/DB_Pager-0.7.tgz) = 3447
diff --git a/databases/pear-DB_Pager/pkg-descr b/databases/pear-DB_Pager/pkg-descr
new file mode 100644
index 00000000000..e09b532b94b
--- /dev/null
+++ b/databases/pear-DB_Pager/pkg-descr
@@ -0,0 +1,8 @@
+DB_Pager retrieve and return information of database result sets.
+
+This class handles all the stuff needed for displaying
+paginated results from a database query of Pear DB.
+including fetching only the needed rows and giving extensive information
+for helping build an HTML or GTK query result display.
+
+WWW: http://pear.php.net/package/DB_Pager