aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
commit31445311fce915521f6c1940134b8dc155688036 (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /databases
parent3672f197c67f0c967088c7faaced7d9627772e4d (diff)
downloadfreebsd-ports-graphics-31445311fce915521f6c1940134b8dc155688036.tar.gz
freebsd-ports-graphics-31445311fce915521f6c1940134b8dc155688036.tar.zst
freebsd-ports-graphics-31445311fce915521f6c1940134b8dc155688036.zip
- Convert to new perl framework
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-AnyEvent-BDB/Makefile3
-rw-r--r--databases/p5-AnyEvent-CouchDB/Makefile3
-rw-r--r--databases/p5-BDB/Makefile3
-rw-r--r--databases/p5-BSON/Makefile3
-rw-r--r--databases/p5-CouchDB-View/Makefile3
-rw-r--r--databases/p5-DBIx-Class-Cursor-Cached/Makefile3
-rw-r--r--databases/p5-DBIx-Safe/Makefile3
-rw-r--r--databases/p5-PostgreSQL-PLPerl-Call/Makefile3
-rw-r--r--databases/p5-PostgreSQL-PLPerl-Trace/Makefile3
-rw-r--r--databases/p5-Search-Xapian/Makefile3
-rw-r--r--databases/p5-Tie-LevelDB/Makefile3
-rw-r--r--databases/xapian-bindings/Makefile2
12 files changed, 23 insertions, 12 deletions
diff --git a/databases/p5-AnyEvent-BDB/Makefile b/databases/p5-AnyEvent-BDB/Makefile
index 7979e0f7d6a..f12f898471f 100644
--- a/databases/p5-AnyEvent-BDB/Makefile
+++ b/databases/p5-AnyEvent-BDB/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-AnyEvent>=3.81:${PORTSDIR}/devel/p5-AnyEvent \
p5-BDB>=1.5:${PORTSDIR}/databases/p5-BDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= AnyEvent::BDB.3
diff --git a/databases/p5-AnyEvent-CouchDB/Makefile b/databases/p5-AnyEvent-CouchDB/Makefile
index 1a4d8bb6135..45f9df4c163 100644
--- a/databases/p5-AnyEvent-CouchDB/Makefile
+++ b/databases/p5-AnyEvent-CouchDB/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= couchdb>=0.9.0:${PORTSDIR}/databases/couchdb \
p5-Scope-Guard>=0:${PORTSDIR}/devel/p5-Scope-Guard
BUILD_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= couchdb-push.1
MAN3= AnyEvent::CouchDB.3 \
diff --git a/databases/p5-BDB/Makefile b/databases/p5-BDB/Makefile
index 50c7cba89c6..41731b9ffc7 100644
--- a/databases/p5-BDB/Makefile
+++ b/databases/p5-BDB/Makefile
@@ -23,7 +23,8 @@ PORTSCOUT= skipv:1.801
CFLAGS+= -I${BDB_INCLUDE_DIR}
LDFLAGS+= ${PTHREAD_LIBS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
USE_BDB= 43+
MAN3= BDB.3
diff --git a/databases/p5-BSON/Makefile b/databases/p5-BSON/Makefile
index 7f91c8382c5..9e4f5603438 100644
--- a/databases/p5-BSON/Makefile
+++ b/databases/p5-BSON/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= BSON.3 \
BSON::Binary.3 \
diff --git a/databases/p5-CouchDB-View/Makefile b/databases/p5-CouchDB-View/Makefile
index 660eb570027..4aac5bc71e2 100644
--- a/databases/p5-CouchDB-View/Makefile
+++ b/databases/p5-CouchDB-View/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= CouchDB::View.3 \
CouchDB::View::Document.3 \
diff --git a/databases/p5-DBIx-Class-Cursor-Cached/Makefile b/databases/p5-DBIx-Class-Cursor-Cached/Makefile
index bb167753ff4..2b7a7073cbc 100644
--- a/databases/p5-DBIx-Class-Cursor-Cached/Makefile
+++ b/databases/p5-DBIx-Class-Cursor-Cached/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-Carp-Clan>=6.0:${PORTSDIR}/devel/p5-Carp-Clan \
TEST_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= DBIx::Class::Cursor::Cached.3
diff --git a/databases/p5-DBIx-Safe/Makefile b/databases/p5-DBIx-Safe/Makefile
index 6da90a3771c..bb620c6cf0b 100644
--- a/databases/p5-DBIx-Safe/Makefile
+++ b/databases/p5-DBIx-Safe/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-DBD-Pg>=1.49:${PORTSDIR}/databases/p5-DBD-Pg \
RUN_DEPENDS= p5-DBD-Pg>=1.49:${PORTSDIR}/databases/p5-DBD-Pg \
p5-DBI>=1.490:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= DBIx::Safe.3
diff --git a/databases/p5-PostgreSQL-PLPerl-Call/Makefile b/databases/p5-PostgreSQL-PLPerl-Call/Makefile
index f3f0562b3b5..723f5301391 100644
--- a/databases/p5-PostgreSQL-PLPerl-Call/Makefile
+++ b/databases/p5-PostgreSQL-PLPerl-Call/Makefile
@@ -17,7 +17,8 @@ COMMENT= Simple interface for calling SQL functions from PostgreSQL PL/Perl
BUILD_DEPENDS= p5-DBI>=1.60.5:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= PostgreSQL::PLPerl::Call.3
diff --git a/databases/p5-PostgreSQL-PLPerl-Trace/Makefile b/databases/p5-PostgreSQL-PLPerl-Trace/Makefile
index a79bd2ca7b9..9d4354c6e71 100644
--- a/databases/p5-PostgreSQL-PLPerl-Trace/Makefile
+++ b/databases/p5-PostgreSQL-PLPerl-Trace/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple way to trace execution of Perl statements in PL/Perl
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= PostgreSQL::PLPerl::Trace.3
diff --git a/databases/p5-Search-Xapian/Makefile b/databases/p5-Search-Xapian/Makefile
index 0979a6075ac..a8ff833612d 100644
--- a/databases/p5-Search-Xapian/Makefile
+++ b/databases/p5-Search-Xapian/Makefile
@@ -23,7 +23,8 @@ PORTSCOUT= limitw:1,even
CC= ${CXX}
CONFIGURE_ARGS= XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Search::Xapian.3 \
Search::Xapian::AssertionError.3 \
diff --git a/databases/p5-Tie-LevelDB/Makefile b/databases/p5-Tie-LevelDB/Makefile
index ba3a1bdd0ea..f71c817923d 100644
--- a/databases/p5-Tie-LevelDB/Makefile
+++ b/databases/p5-Tie-LevelDB/Makefile
@@ -18,7 +18,8 @@ COMMENT= A Perl Interface to the Google LevelDB NoSQL database
LIB_DEPENDS= leveldb:${PORTSDIR}/databases/leveldb
MAKE_ARGS= CC=${CXX}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
USES= gmake
MAN3= Tie::LevelDB.3
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 584d82149a9..9c58c9026db 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -37,7 +37,7 @@ PLIST_SUB+= LUA="@comment "
.if ${PORT_OPTIONS:MPERL}
CONFIGURE_ARGS+=--with-perl
CONFIGURE_ENV+= PERL_LIB="${SITE_PERL}"
-USE_PERL5= yes
+USES= perl5
PLIST_SUB+= PERL=""
.else
PLIST_SUB+= PERL="@comment "