aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-03-07 05:45:35 +0800
committerkwm <kwm@FreeBSD.org>2014-03-07 05:45:35 +0800
commit432d4cbe785f3add7ad736099611f014be40c0da (patch)
treef18bb07b20e22794381082961fac477b3b5c9ebb /databases
parent30298a56d9005893432fcb0858c25060456fbc7f (diff)
downloadfreebsd-ports-graphics-432d4cbe785f3add7ad736099611f014be40c0da.tar.gz
freebsd-ports-graphics-432d4cbe785f3add7ad736099611f014be40c0da.tar.zst
freebsd-ports-graphics-432d4cbe785f3add7ad736099611f014be40c0da.zip
Unbreak on 10+
Stagify. Add USES=desktop-file-utils and libtool.
Diffstat (limited to 'databases')
-rw-r--r--databases/glom/Makefile10
-rw-r--r--databases/glom/files/patch-glom_frame-glom.cc11
-rw-r--r--databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc13
-rw-r--r--databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc13
-rw-r--r--databases/glom/pkg-plist1
5 files changed, 44 insertions, 4 deletions
diff --git a/databases/glom/Makefile b/databases/glom/Makefile
index 4545f9ad941..a00d70c91ef 100644
--- a/databases/glom/Makefile
+++ b/databases/glom/Makefile
@@ -4,7 +4,7 @@
PORTNAME= glom
PORTVERSION= 1.12.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,7 +29,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USE_BZIP2= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-USES= gettext pathfix shared-mime-info gmake pkgconfig
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ shared-mime-info
USE_GNOME= gnomedocutils gnomeprefix pygnomeextras
USE_LDCONFIG= yes
USE_PGSQL= yes
@@ -43,5 +44,8 @@ INSTALLS_ICONS= yes
BUILD_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
RUN_DEPENDS+= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-NO_STAGE= yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libglom-1.12.so.0.0.0
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/glom_1_12.so
+
.include <bsd.port.mk>
diff --git a/databases/glom/files/patch-glom_frame-glom.cc b/databases/glom/files/patch-glom_frame-glom.cc
new file mode 100644
index 00000000000..361bfd1a870
--- /dev/null
+++ b/databases/glom/files/patch-glom_frame-glom.cc
@@ -0,0 +1,11 @@
+--- glom/frame_glom.cc.orig 2014-03-06 22:06:42.000000000 +0100
++++ glom/frame_glom.cc 2014-03-06 22:06:55.000000000 +0100
+@@ -1583,7 +1583,7 @@
+ //Get the fields information from the database:
+ Base_DB::type_vec_fields fieldsDatabase = Base_DB::get_fields_for_table_from_database(m_table_name);
+
+- Document* pDoc = dynamic_cast<const Document*>(get_document());
++ Document* pDoc = dynamic_cast<Document*>(get_document());
+ if(pDoc)
+ {
+ bool document_must_be_updated = false;
diff --git a/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc b/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc
new file mode 100644
index 00000000000..54e4e181abb
--- /dev/null
+++ b/databases/glom/files/patch-glom_mode-design_fields_box-db-table-definition.cc
@@ -0,0 +1,13 @@
+--- glom/mode_design/fields/box_db_table_definition.cc.orig 2014-03-06 22:10:39.000000000 +0100
++++ glom/mode_design/fields/box_db_table_definition.cc 2014-03-06 22:16:25.000000000 +0100
+@@ -143,8 +143,8 @@
+ const sharedptr<const Field>& field = *iter;
+
+ //Name:
+- Gtk::TreeModel::iterator iter= m_AddDel.add_item(field->get_name());
+- fill_field_row(iter, field);
++ Gtk::TreeModel::iterator tree_iter= m_AddDel.add_item(field->get_name());
++ fill_field_row(tree_iter, field);
+ }
+
+ result = true;
diff --git a/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc b/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc
new file mode 100644
index 00000000000..6f8068b40ff
--- /dev/null
+++ b/databases/glom/files/patch-glom_mode-design_layout_layout-item-dialogs_box-formatting.cc
@@ -0,0 +1,13 @@
+--- glom/mode_design/layout/layout_item_dialogs/box_formatting.cc.orig 2014-03-06 22:26:17.000000000 +0100
++++ glom/mode_design/layout/layout_item_dialogs/box_formatting.cc 2014-03-06 22:26:37.000000000 +0100
+@@ -187,8 +187,8 @@
+ {
+ //Display the value in the choices list as it would be displayed in the format:
+ const Glib::ustring value_text = Conversions::get_text_for_gda_value(m_field->get_glom_type(), *iter, format.m_numeric_format);
+- Gtk::TreeModel::iterator iter = m_adddel_choices_custom->add_item(value_text);
+- m_adddel_choices_custom->set_value(iter, m_col_index_custom_choices, value_text);
++ Gtk::TreeModel::iterator tree_iter = m_adddel_choices_custom->add_item(value_text);
++ m_adddel_choices_custom->set_value(tree_iter, m_col_index_custom_choices, value_text);
+ }
+
+ m_radiobutton_choices_custom->set_active(format.get_has_custom_choices());
diff --git a/databases/glom/pkg-plist b/databases/glom/pkg-plist
index 1b30af8857f..9c31251127f 100644
--- a/databases/glom/pkg-plist
+++ b/databases/glom/pkg-plist
@@ -213,7 +213,6 @@ share/locale/sv/LC_MESSAGES/glom.mo
share/locale/tr/LC_MESSAGES/glom.mo
share/locale/vi/LC_MESSAGES/glom.mo
share/locale/zh_CN/LC_MESSAGES/glom.mo
-share/mime/application/x-glom.xml
share/mime/packages/glom.xml
share/omf/glom/glom-C.omf
share/omf/glom/glom-de.omf