aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2016-04-12 21:20:53 +0800
committerdemon <demon@FreeBSD.org>2016-04-12 21:20:53 +0800
commit4b01bb202f04932b33bee9065c1da821e35160e5 (patch)
tree5aee2c0c640e9cb8ab2f8509095715fcbf749bcf /databases
parent8c0926afec1999be6f2a4e01deb64158081d30f7 (diff)
downloadfreebsd-ports-graphics-4b01bb202f04932b33bee9065c1da821e35160e5.tar.gz
freebsd-ports-graphics-4b01bb202f04932b33bee9065c1da821e35160e5.tar.zst
freebsd-ports-graphics-4b01bb202f04932b33bee9065c1da821e35160e5.zip
Add pymongo28 port: the upcoming motor port
(https://pypi.python.org/pypi/motor) requires exactly that version. This port should be deleted when motor port will accept newer versions of pymongo.
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pymongo28/Makefile21
-rw-r--r--databases/pymongo28/distinfo2
-rw-r--r--databases/pymongo28/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 332d39e1375..9337db7473a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -801,6 +801,7 @@
SUBDIR += py35-sqlite3
SUBDIR += pydbx
SUBDIR += pymongo
+ SUBDIR += pymongo28
SUBDIR += pypy-gdbm
SUBDIR += pypy-sqlite3
SUBDIR += pyspatialite
diff --git a/databases/pymongo28/Makefile b/databases/pymongo28/Makefile
new file mode 100644
index 00000000000..50e499a430e
--- /dev/null
+++ b/databases/pymongo28/Makefile
@@ -0,0 +1,21 @@
+# Created by: wen@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= pymongo
+PORTVERSION= 2.8
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 28
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Python driver for MongoDB
+
+LICENSE= APACHE20
+
+CONFLICTS_INSTALL= py[0-9][0-9]-pymongo
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/databases/pymongo28/distinfo b/databases/pymongo28/distinfo
new file mode 100644
index 00000000000..66bb3d0bd13
--- /dev/null
+++ b/databases/pymongo28/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pymongo-2.8.tar.gz) = 0543f65364fb54fb54b954136cf6b5e689ab12a7c1d15c59c52d3d0c5fa73935
+SIZE (pymongo-2.8.tar.gz) = 394529
diff --git a/databases/pymongo28/pkg-descr b/databases/pymongo28/pkg-descr
new file mode 100644
index 00000000000..9592e8cf627
--- /dev/null
+++ b/databases/pymongo28/pkg-descr
@@ -0,0 +1,6 @@
+The PyMongo distribution contains tools for interacting with
+the Mongo database from Python. The pymongo package is a native
+Python driver for the Mongo database. The gridfs package is a
+gridfs implementation on top of pymongo.
+
+WWW: http://github.com/mongodb/mongo-python-driver