aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-05-10 21:49:03 +0800
committergahr <gahr@FreeBSD.org>2012-05-10 21:49:03 +0800
commit524cfb196083ecd618c8a88aa77838c681a67a76 (patch)
treefc63e0be6e5dda06168f973054ffebb3f5020ea6 /databases
parent26daca957b0aedc51fdba1b7b1366325100bc177 (diff)
downloadfreebsd-ports-graphics-524cfb196083ecd618c8a88aa77838c681a67a76.tar.gz
freebsd-ports-graphics-524cfb196083ecd618c8a88aa77838c681a67a76.tar.zst
freebsd-ports-graphics-524cfb196083ecd618c8a88aa77838c681a67a76.zip
- Add a patch (http://tdbc.tcl.tk/index.cgi/tktview?name=0dda7dbb73)
- Respect PREFIX
Diffstat (limited to 'databases')
-rw-r--r--databases/tdbc/Makefile3
-rw-r--r--databases/tdbc/files/patch-tdbcodbc-generic_tdbcodbc.c17
2 files changed, 19 insertions, 1 deletions
diff --git a/databases/tdbc/Makefile b/databases/tdbc/Makefile
index 545ac37b93b..23eaf150beb 100644
--- a/databases/tdbc/Makefile
+++ b/databases/tdbc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tdbc
DISTVERSION= 1.0b17
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://tdbc.tcl.tk/index.cgi/tarball/
DISTFILES= ${PORTNAME:U}-${FOSSIL_HASH}.${EXTRACT_SUFX}?uuid=${FOSSIL_HASH}
@@ -121,7 +122,7 @@ do-install:
cd ${WRKSRC}/${module} && ${MAKE} ${INSTALL_TARGET}
.endfor
.if defined(WITH_SQLITE)
- ${INSTALL_DATA} ${WRKDIR}/pkgIndex.tcl ${TCL_LIBDIR}/tdbc
+ ${INSTALL_DATA} ${WRKDIR}/pkgIndex.tcl ${TCL_LIBDIR:S/${LOCALBASE}/${PREFIX}/}/tdbc
.endif
test:
diff --git a/databases/tdbc/files/patch-tdbcodbc-generic_tdbcodbc.c b/databases/tdbc/files/patch-tdbcodbc-generic_tdbcodbc.c
new file mode 100644
index 00000000000..8a9a05e6add
--- /dev/null
+++ b/databases/tdbc/files/patch-tdbcodbc-generic_tdbcodbc.c
@@ -0,0 +1,17 @@
+--- tdbcodbc/generic/tdbcodbc.c,orig 2011-08-01 16:50:38.000000000 +0200
++++ tdbcodbc/generic/tdbcodbc.c 2012-05-09 10:52:56.000000000 +0200
+@@ -4092,10 +4092,10 @@
+ SQLLEN colAllocLen = BUFSIZE * sizeof(SQLWCHAR);
+ /* Current allocated size of the buffer,
+ * in bytes */
+- SQLLEN colLen; /* Actual size of the return value, in bytes */
+- SQLINTEGER colLong; /* Integer value of the column */
+- SQLBIGINT colWide; /* Wide-integer value of the column */
+- SQLDOUBLE colDouble; /* Double value of the column */
++ SQLLEN colLen = 0; /* Actual size of the return value, in bytes */
++ SQLINTEGER colLong = 0L; /* Integer value of the column */
++ SQLBIGINT colWide = 0; /* Wide-integer value of the column */
++ SQLDOUBLE colDouble = 0.0; /* Double value of the column */
+ Tcl_DString colDS; /* Column expressed as a Tcl_DString */
+ Tcl_Obj* colObj; /* Column expressed as a Tcl_Obj */
+ SQLRETURN rc; /* ODBC result code */