aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2013-08-23 00:40:33 +0800
committergblach <gblach@FreeBSD.org>2013-08-23 00:40:33 +0800
commit5273902e957aba1e9f69b3327564f28aed2d7855 (patch)
treedfe970c2fe5aa626f38c0aa1d76acbff024aacb3 /databases
parentf2f0f7f18ea0340fe156a3d6249d0270c2d1bf82 (diff)
downloadfreebsd-ports-graphics-5273902e957aba1e9f69b3327564f28aed2d7855.tar.gz
freebsd-ports-graphics-5273902e957aba1e9f69b3327564f28aed2d7855.tar.zst
freebsd-ports-graphics-5273902e957aba1e9f69b3327564f28aed2d7855.zip
- Add new port: databases/redigo
Redigo is a Go client for the Redis database. It supports all Redis commands, pipelining, publish/subscribe and connection pooling. Approved by: crees (mentor)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/redigo/Makefile26
-rw-r--r--databases/redigo/distinfo2
-rw-r--r--databases/redigo/pkg-descr4
-rw-r--r--databases/redigo/pkg-plist17
5 files changed, 50 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 8ba93cf3ed7..8f10f980348 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -794,6 +794,7 @@
SUBDIR += rdb
SUBDIR += rdfdb
SUBDIR += recutils
+ SUBDIR += redigo
SUBDIR += redis
SUBDIR += redis-devel
SUBDIR += rrdman
diff --git a/databases/redigo/Makefile b/databases/redigo/Makefile
new file mode 100644
index 00000000000..e166f7013ba
--- /dev/null
+++ b/databases/redigo/Makefile
@@ -0,0 +1,26 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= redigo
+PORTVERSION= 20130702
+CATEGORIES= databases
+MASTER_SITES= LOCAL/gblach/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Go client for the Redis database
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/redis
+SUBLIBDIR= github.com/garyburd/${PORTNAME}
+GO_PKGNAME= ${SUBLIBDIR}/redis
+
+do-install:
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/redis.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
+.for f in conn.go doc.go log.go pool.go pubsub.go redis.go reply.go scan.go script.go
+ ${INSTALL_DATA} ${GO_WRKSRC}/${f} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
+.endfor
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/redigo/distinfo b/databases/redigo/distinfo
new file mode 100644
index 00000000000..4522c15437a
--- /dev/null
+++ b/databases/redigo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (redigo-20130702.tar.gz) = 2352421f163a2031c08eb8eb3d3eaea23cd6cc48fe1c3d3a01cb687fdb311fca
+SIZE (redigo-20130702.tar.gz) = 22075
diff --git a/databases/redigo/pkg-descr b/databases/redigo/pkg-descr
new file mode 100644
index 00000000000..e4add0deb66
--- /dev/null
+++ b/databases/redigo/pkg-descr
@@ -0,0 +1,4 @@
+Redigo is a Go client for the Redis database. It supports all Redis commands,
+pipelining, publish/subscribe and connection pooling.
+
+WWW: https://github.com/garyburd/redigo
diff --git a/databases/redigo/pkg-plist b/databases/redigo/pkg-plist
new file mode 100644
index 00000000000..7176b2ecdfa
--- /dev/null
+++ b/databases/redigo/pkg-plist
@@ -0,0 +1,17 @@
+%%GO_LIBDIR%%/github.com/garyburd/redigo/redis.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/conn.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/doc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/log.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pool.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pubsub.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/redis.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/reply.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/scan.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/script.go
+@dirrm %%GO_LIBDIR%%/github.com/garyburd/redigo
+@dirrmtry %%GO_LIBDIR%%/github.com/garyburd
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrm %%GO_SRCDIR%%/github.com/garyburd/redigo
+@dirrmtry %%GO_SRCDIR%%/github.com/garyburd
+@dirrmtry %%GO_SRCDIR%%/github.com