aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /databases
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-graphics-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-graphics-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-graphics-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'databases')
-rw-r--r--databases/linux-c6-sqlite3/Makefile7
-rw-r--r--databases/linux-f10-sqlite3/Makefile4
-rw-r--r--databases/linux-oracle-instantclient-basic/Makefile3
-rw-r--r--databases/linux-oracle-instantclient-sqlplus/Makefile3
4 files changed, 5 insertions, 12 deletions
diff --git a/databases/linux-c6-sqlite3/Makefile b/databases/linux-c6-sqlite3/Makefile
index 181b214b500..99052c9cdfe 100644
--- a/databases/linux-c6-sqlite3/Makefile
+++ b/databases/linux-c6-sqlite3/Makefile
@@ -11,14 +11,11 @@ COMMENT= Library that implements an embeddable SQL database engine (Linux CentOS
CONFLICTS= linux-f8-sqlite3-[0-9]* linux-f10-sqlite3-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= c6
RPMVERSION= 1.el6_7.2
-USE_LINUX_RPM= yes
-BRANDELF_FILES= usr/bin/sqlite3
+USES= linux:c6
USE_LDCONFIG= yes
+USE_LINUX_RPM= yes
-DOCSDIR= ${PREFIX}/usr/share/doc/sqlite-${PORTVERSION}
PORTDOCS= README
DESCR= ${.CURDIR}/../${PORTNAME}3/pkg-descr
diff --git a/databases/linux-f10-sqlite3/Makefile b/databases/linux-f10-sqlite3/Makefile
index c7128fe06bd..88c8a5e7491 100644
--- a/databases/linux-f10-sqlite3/Makefile
+++ b/databases/linux-f10-sqlite3/Makefile
@@ -5,7 +5,6 @@ PORTNAME= sqlite3
PORTVERSION= 3.5.9
PORTREVISION= 2
CATEGORIES= databases linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
DISTNAME= sqlite-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
@@ -13,11 +12,10 @@ COMMENT= Library that implements an embeddable SQL database engine (Linux Fedora
CONFLICTS= linux-f8-sqlite3-[0-9]*
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
RPMVERSION= 4.fc10
-BRANDELF_FILES= usr/bin/sqlite3
USE_LDCONFIG= yes
PLIST_FILES= usr/bin/sqlite3 usr/lib/libsqlite3.so.0 \
diff --git a/databases/linux-oracle-instantclient-basic/Makefile b/databases/linux-oracle-instantclient-basic/Makefile
index 5c0bed4c188..3ecd70e787f 100644
--- a/databases/linux-oracle-instantclient-basic/Makefile
+++ b/databases/linux-oracle-instantclient-basic/Makefile
@@ -20,8 +20,7 @@ DISTINFO_FILE= ${MASTERDIR}/distinfo.i386
RESTRICTED= Packaging prohibited by Oracle license
-USES= zip
-USE_LINUX= yes
+USES= linux zip
USE_LINUX_PREFIX= yes
ORACLEVERSION= 10.2.0.3
diff --git a/databases/linux-oracle-instantclient-sqlplus/Makefile b/databases/linux-oracle-instantclient-sqlplus/Makefile
index 105ed09e144..6374a519a24 100644
--- a/databases/linux-oracle-instantclient-sqlplus/Makefile
+++ b/databases/linux-oracle-instantclient-sqlplus/Makefile
@@ -23,8 +23,7 @@ RESTRICTED= Packaging prohibited by Oracle license
# base
RUN_DEPENDS+= linux-oracle-instantclient-basic>0:databases/linux-oracle-instantclient-basic
-USES= zip
-USE_LINUX= c6
+USES= linux:c6 zip
USE_LINUX_PREFIX= yes
ORACLEVERSION= 10.2.0.3