aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-02 05:42:51 +0800
committermiwi <miwi@FreeBSD.org>2009-05-02 05:42:51 +0800
commit71fa8defdc60e8b08c90fb5c488074fd5bbb9ad1 (patch)
tree90aced6257bf626ea5a9c52593e3210d1577591d /databases
parent25eb501bebc04e5430337983df43783d10dc80af (diff)
downloadfreebsd-ports-graphics-71fa8defdc60e8b08c90fb5c488074fd5bbb9ad1.tar.gz
freebsd-ports-graphics-71fa8defdc60e8b08c90fb5c488074fd5bbb9ad1.tar.zst
freebsd-ports-graphics-71fa8defdc60e8b08c90fb5c488074fd5bbb9ad1.zip
DBIx::Class::QueryLog logs each transaction and query executed so you can
analyze what happened in the session. WWW: http://search.cpan.org/dist/DBIx-Class-QueryLog/ PR: ports/134095 Submitted by: Andrey Kostenko <andrey at kostenko.name>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Class-QueryLog/Makefile25
-rw-r--r--databases/p5-DBIx-Class-QueryLog/distinfo3
-rw-r--r--databases/p5-DBIx-Class-QueryLog/pkg-descr4
-rw-r--r--databases/p5-DBIx-Class-QueryLog/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7cb1c5c46b4..6f4c992162e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -303,6 +303,7 @@
SUBDIR += p5-DBIx-Class-InflateColumn-IP
SUBDIR += p5-DBIx-Class-IntrospectableM2M
SUBDIR += p5-DBIx-Class-Loader
+ SUBDIR += p5-DBIx-Class-QueryLog
SUBDIR += p5-DBIx-Class-ResultSet-RecursiveUpdate
SUBDIR += p5-DBIx-Class-Schema-Loader
SUBDIR += p5-DBIx-Class-TimeStamp
diff --git a/databases/p5-DBIx-Class-QueryLog/Makefile b/databases/p5-DBIx-Class-QueryLog/Makefile
new file mode 100644
index 00000000000..c66a5fc6917
--- /dev/null
+++ b/databases/p5-DBIx-Class-QueryLog/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Log-Dispatch-Configurator-YAML
+# Date created: 28 May 2008
+# Whom: Andrey Kostenko <andrey@kostenko.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-QueryLog
+PORTVERSION= 1.1.5
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Log queries for later analysis
+
+RUN_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::QueryLog.3 DBIx::Class::QueryLog::Query.3 DBIx::Class::QueryLog::Transaction.3 DBIx::Class::QueryLog::Analyzer.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Class-QueryLog/distinfo b/databases/p5-DBIx-Class-QueryLog/distinfo
new file mode 100644
index 00000000000..a3b933c25fd
--- /dev/null
+++ b/databases/p5-DBIx-Class-QueryLog/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Class-QueryLog-1.1.5.tar.gz) = 6ebefdf6b7c26fa2ca667ff8005bbae7
+SHA256 (DBIx-Class-QueryLog-1.1.5.tar.gz) = f9d6be6ab5785ce71791453d34cd1389d545456687cc393a373306728617cd99
+SIZE (DBIx-Class-QueryLog-1.1.5.tar.gz) = 25448
diff --git a/databases/p5-DBIx-Class-QueryLog/pkg-descr b/databases/p5-DBIx-Class-QueryLog/pkg-descr
new file mode 100644
index 00000000000..0bc29e01cb8
--- /dev/null
+++ b/databases/p5-DBIx-Class-QueryLog/pkg-descr
@@ -0,0 +1,4 @@
+DBIx::Class::QueryLog logs each transaction and query executed so you can
+analyze what happened in the session.
+
+WWW: http://search.cpan.org/dist/DBIx-Class-QueryLog/
diff --git a/databases/p5-DBIx-Class-QueryLog/pkg-plist b/databases/p5-DBIx-Class-QueryLog/pkg-plist
new file mode 100644
index 00000000000..97ce12771bd
--- /dev/null
+++ b/databases/p5-DBIx-Class-QueryLog/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/DBIx/Class/QueryLog/Analyzer.pm
+%%SITE_PERL%%/DBIx/Class/QueryLog/Transaction.pm
+%%SITE_PERL%%/DBIx/Class/QueryLog/Query.pm
+%%SITE_PERL%%/DBIx/Class/QueryLog.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/QueryLog/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Class/QueryLog
+@dirrmtry %%SITE_PERL%%/DBIx/Class/QueryLog