aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-11-07 17:28:21 +0800
committerpi <pi@FreeBSD.org>2015-11-07 17:28:21 +0800
commita1017631cdfcf238c234cadcf4b8201b1424a762 (patch)
treec6abeb19ba8abdd9c02af9f24147aef7327b6cb8 /databases
parent532ac30ad7b4b9d05f16ddc19ca2af0d3af194b0 (diff)
downloadfreebsd-ports-graphics-a1017631cdfcf238c234cadcf4b8201b1424a762.tar.gz
freebsd-ports-graphics-a1017631cdfcf238c234cadcf4b8201b1424a762.tar.zst
freebsd-ports-graphics-a1017631cdfcf238c234cadcf4b8201b1424a762.zip
databases/cego: 2.26.7 -> 2.26.9
- Version passed concurrent load test with 10 million concurrent operations ( random insert, update and delete on one table with 2 processes ) - Fix in CegoFileHandler::allocatePage, In case of page exceed with appendMode = true, a second try is done with appendMode = false - Small fix in CegoObjectManager::reorgObject, ref page id information for append mode is set to new last page id - Small fix in CegoSelect::filterRefs, allow expressions with constant values ( getAttrRefList= 0 ) in aggregation - Locking improvements for delete and update operations. All delete operations are done now via transactions ( introduced CegoTableManager::deleteDataTableAtomic ). This allows to use a shared lock as the table lock for using the table (CegoDistManager::deleteLocalDataTable and CegoDistManager::updateLocalDataTable ) As a result, a table can be accessed in parallel during a ( long running ) delete operation on the table( e.g. delete from table). E.g. select count(*) from table will not block anymore, rather indicates the remaining number of tuples in the table. This modification is still under investigation and must verfied ( also in combination with btree/index objects on the table ) - Fix in CegoBTreeManager::deleteBTree, the relevance value was not calculated correctly Fix in CegoQuery, cache invalidation is done before query operations. Otherwise, if the query is aborted, an exception is thrown and the cache is not cleaned - Small modifications on cgblow load simulation client - Changed locking for delete an update operations to exclusive due to concurrency prpblems with btree operations - Added page locking to AVLIndexManager and AVLIndexCursor - Improvements for locking done. Since locking is done on page level, Insert and delete operations can be done now in parallel . For this locking had to be introduced in CegoBtreeManager::insertBTree and CegoBTreeManager::deleteBTree Further performance path for grouping queries in CegoGroupSpace. Since the current grouping key is stored now in the class variable _groupSchema, some expensive list copy operations could be avoided. This improves performance for about 4%. Submitted by: Bjoern Lemke <lemke@lemke-it.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/cego/Makefile2
-rw-r--r--databases/cego/distinfo4
-rw-r--r--databases/cego/pkg-plist1
3 files changed, 4 insertions, 3 deletions
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index a384c1da320..d5860f10a0a 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cego
-PORTVERSION= 2.26.7
+PORTVERSION= 2.26.9
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
diff --git a/databases/cego/distinfo b/databases/cego/distinfo
index c17dbe93ccd..ea354ede520 100644
--- a/databases/cego/distinfo
+++ b/databases/cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cego-2.26.7.tar.gz) = 9843a5f00cdc0b806a1e2fc65b8124b36b88d6a2a9cdb3fcc405603d5dcf272b
-SIZE (cego-2.26.7.tar.gz) = 1226686
+SHA256 (cego-2.26.9.tar.gz) = 31f38e21226ff20cd5fc81db7568297a6e8364f652e0c6276c19931aaeab7ef7
+SIZE (cego-2.26.9.tar.gz) = 1227953
diff --git a/databases/cego/pkg-plist b/databases/cego/pkg-plist
index 91e6534bc20..f6fb1140ee7 100644
--- a/databases/cego/pkg-plist
+++ b/databases/cego/pkg-plist
@@ -137,5 +137,6 @@ lib/libcgwrap.so.2.0.0
%%DATADIR%%/cgbackup
%%DATADIR%%/cgmkdb
%%DATADIR%%/cgrecover
+%%DATADIR%%/cgsimload
%%DATADIR%%/startdb
%%DATADIR%%/stopdb