aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-17 07:27:39 +0800
committerswills <swills@FreeBSD.org>2011-07-17 07:27:39 +0800
commita388de7e90defb81fe12e202dd827ffb1081518c (patch)
tree825fa2a3b3851d15e0eb64f436d06d29b38c6aee /databases
parentd7708e83c84e5ba5e3e8d0aaf6c2aaef11250209 (diff)
downloadfreebsd-ports-graphics-a388de7e90defb81fe12e202dd827ffb1081518c.tar.gz
freebsd-ports-graphics-a388de7e90defb81fe12e202dd827ffb1081518c.tar.zst
freebsd-ports-graphics-a388de7e90defb81fe12e202dd827ffb1081518c.zip
MemcacheQ is a Simple Queue Service over Memcache.
Features: * damn simple * very fast * multiple queue * concurrent well * memcache protocol compatible WWW: http://memcachedb.org/memcacheq/ PR: ports/153422 Submitted by: Mikhail T. <m.tsatsenko at gmail.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/memcacheq/Makefile46
-rw-r--r--databases/memcacheq/distinfo2
-rw-r--r--databases/memcacheq/files/memcacheq.in39
-rw-r--r--databases/memcacheq/pkg-descr11
5 files changed, 99 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index a81c093f71b..f0b0168957b 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -192,6 +192,7 @@
SUBDIR += memcached
SUBDIR += memcached12
SUBDIR += memcachedb
+ SUBDIR += memcacheq
SUBDIR += mergeant
SUBDIR += metakit
SUBDIR += mird
diff --git a/databases/memcacheq/Makefile b/databases/memcacheq/Makefile
new file mode 100644
index 00000000000..f396e86d596
--- /dev/null
+++ b/databases/memcacheq/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: databases/memcacheq
+# Date created: 2010-12-23
+# Whom: Mikhail T. <m.tsatsenko@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memcacheq
+PORTVERSION= 0.2.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
+
+MAINTAINER= m.tsatsenko@gmail.com
+COMMENT= Simple queue service over Memcache
+
+LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+
+CFLAGS+= -I"${BDB_INCLUDE_DIR}"
+LDFLAGS+= -l"${BDB_LIB_NAME}" -L"${LOCALBASE}/lib"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+USE_RC_SUBR= memcacheq
+USE_BDB= 47+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --with-bdb=${LOCALBASE} --enable-threads
+
+PLIST_FILES= bin/memcacheq
+PLIST_DIRS= ${DOCSDIR_REL}
+PORTDOCS= README
+
+MCQDIR?= /var/db/memcacheq
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ ${MKDIR} ${MCQDIR} || ${TRUE}
+ ${CHOWN} nobody:nobody ${MCQDIR}
+
+.include <bsd.port.post.mk>
diff --git a/databases/memcacheq/distinfo b/databases/memcacheq/distinfo
new file mode 100644
index 00000000000..6cbc78eaa2c
--- /dev/null
+++ b/databases/memcacheq/distinfo
@@ -0,0 +1,2 @@
+SHA256 (memcacheq-0.2.0.tar.gz) = b314c46e1fb80d33d185742afe3b9a4fadee5575155cb1a63292ac2f28393046
+SIZE (memcacheq-0.2.0.tar.gz) = 131519
diff --git a/databases/memcacheq/files/memcacheq.in b/databases/memcacheq/files/memcacheq.in
new file mode 100644
index 00000000000..1816af64026
--- /dev/null
+++ b/databases/memcacheq/files/memcacheq.in
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# PROVIDE: memcacheq
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf to run memcacheq:
+#
+# memcacheq_enable (bool): Set it to "YES" to enable memcacheq.
+# Default is "NO".
+# memcacheq_flags (flags): Set extra flags here.
+# Default is empty "".
+# memcacheq_user (user): Set user to run memcacheq.
+# Default is "nobody".
+#
+
+. /etc/rc.subr
+
+name="memcacheq"
+rcvar=${name}_enable
+
+load_rc_config ${name}
+
+: ${memcacheq_enable="NO"}
+: ${memcacheq_user="nobody"}
+: ${memcacheq_pidfile="/var/db/memcacheq/memcacheq.pid"}
+
+stop_postcmd()
+{
+ sleep 3
+ kill -9 `cat ${pidfile}`
+}
+
+pidfile=${memcacheq_pidfile}
+command=%%PREFIX%%/bin/memcacheq
+command_args="-d -N -H /var/db/memcacheq -R -L 1024 -B 1024 -u ${memcacheq_user} -P ${pidfile}"
+
+stop_postcmd="stop_postcmd"
+
+run_rc_command "$1"
diff --git a/databases/memcacheq/pkg-descr b/databases/memcacheq/pkg-descr
new file mode 100644
index 00000000000..2102ae62fa3
--- /dev/null
+++ b/databases/memcacheq/pkg-descr
@@ -0,0 +1,11 @@
+MemcacheQ is a Simple Queue Service over Memcache.
+
+Features:
+
+ * damn simple
+ * very fast
+ * multiple queue
+ * concurrent well
+ * memcache protocol compatible
+
+WWW: http://memcachedb.org/memcacheq/