aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-07 00:29:04 +0800
committerrafan <rafan@FreeBSD.org>2006-07-07 00:29:04 +0800
commitaaaafe8417f5149465adf642227a1c75bb94ba6e (patch)
tree6ecc1088e278a3b7edcdac230ed0d14ee57a566a /databases
parent9a2c3afbe28e3ed2f8b1d41a8602fcde44fb3256 (diff)
downloadfreebsd-ports-graphics-aaaafe8417f5149465adf642227a1c75bb94ba6e.tar.gz
freebsd-ports-graphics-aaaafe8417f5149465adf642227a1c75bb94ba6e.tar.zst
freebsd-ports-graphics-aaaafe8417f5149465adf642227a1c75bb94ba6e.zip
- Update to 1.1.3
- Use GCC 3.2+ to build on 4.x - Remove duplicate logic of detecting PGSQL_VER PR: 99820 Submitted by: maintainer Approved by: delphij (mentor, implicit)
Diffstat (limited to 'databases')
-rw-r--r--databases/postgis/Makefile13
-rw-r--r--databases/postgis/distinfo7
-rw-r--r--databases/postgis/files/patch-lwgeom12
3 files changed, 13 insertions, 19 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index e69305f2266..5b3a1058122 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -6,19 +6,20 @@
#
PORTNAME= postgis
-DISTVERSION= 1.1.2
+DISTVERSION= 1.1.3
CATEGORIES= databases
MASTER_SITES= http://postgis.refractions.net/download/
MAINTAINER= anderson@cnpm.embrapa.br
COMMENT= Adds support for geographic objects to PostgreSQL databases
+BUILD_DEPENDS= bison2:${PORTSDIR}/devel/bison2
LIB_DEPENDS= proj.5:${PORTSDIR}/graphics/proj
RUN_DEPENDS= postmaster:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+USE_GCC= 3.2+
USE_PGSQL= yes
USE_GMAKE= yes
-USE_BISON= yes
USE_PERL5_BUILD= yes
INSTALL_TARGET= install
@@ -35,14 +36,6 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/postgis \
.include <bsd.port.pre.mk>
-#Setting/finding PostgreSQL version we want.
-.if exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
-.else
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-.endif
-
-
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html/chunk.xsl:${PORTSDIR}/textproc/docbook-xsl
diff --git a/databases/postgis/distinfo b/databases/postgis/distinfo
index e28b550d594..26c8b001337 100644
--- a/databases/postgis/distinfo
+++ b/databases/postgis/distinfo
@@ -1,3 +1,4 @@
-MD5 (postgis-1.1.2.tar.gz) = 4b170cc30d9b7fec493fe779e46aa50c
-SHA256 (postgis-1.1.2.tar.gz) = 5d63b1875e6dd8610001ad89d97351eaaf1c3205fc6ec57365e2bb9f6b990fb5
-SIZE (postgis-1.1.2.tar.gz) = 1547680
+SIZE (postgis-1.1.3.tar.gz) = 1619568
+MD5 (postgis-1.1.3.tar.gz) = 555d00f3d96738dd53574aecad4d9a9f
+SHA256 (postgis-1.1.3.tar.gz) = 0fde3d9eff68f3b19b002d60c8236f2ee1ec88d583ca4294956a6570e855db07
+
diff --git a/databases/postgis/files/patch-lwgeom b/databases/postgis/files/patch-lwgeom
index f582e2ea009..4e4d069b84e 100644
--- a/databases/postgis/files/patch-lwgeom
+++ b/databases/postgis/files/patch-lwgeom
@@ -1,11 +1,11 @@
---- lwgeom/Makefile Wed Dec 28 17:39:49 2005
-+++ lwgeom/Makefile Wed Dec 28 17:41:22 2005
-@@ -128,7 +128,7 @@
+--- lwgeom/Makefile Sun Jun 25 20:59:32 2006
++++ lwgeom/Makefile Wed Jul 5 16:29:07 2006
+@@ -129,7 +129,7 @@
$(PERL) ../utils/postgis_proc_upgrade.pl ../lwpostgis.sql > ../lwpostgis_upgrade.sql
- ../lwpostgis.sql: lwpostgis.sql.in
+ ../lwpostgis.sql: lwpostgis.sql.in long_xact.sql
- cpp -P -traditional-cpp -DUSE_VERSION=$(USE_VERSION) $< | sed -e 's:@MODULE_FILENAME@:$(MODULE_FILENAME):g;s:@POSTGIS_VERSION@:$(POSTGIS_VERSION):g;s:@POSTGIS_SCRIPTS_VERSION@:$(SCRIPTS_VERSION):g;s/@POSTGIS_BUILD_DATE@/$(POSTGIS_BUILD_DATE)/g' | grep -v '^#' > $@
+ cpp -P -traditional-cpp -DUSE_VERSION=$(USE_VERSION) $< | sed -e 's:@MODULE_FILENAME@:$$libdir/liblwgeom.so.1:g;s:@POSTGIS_VERSION@:$(POSTGIS_VERSION):g;s:@POSTGIS_SCRIPTS_VERSION@:$(SCRIPTS_VERSION):g;s/@POSTGIS_BUILD_DATE@/$(POSTGIS_BUILD_DATE)/g' | grep -v '^#' > $@
- install: all install-lib-shared install-lwgeom-scripts
-
+ ../regress/lwpostgis.sql: lwpostgis.sql.in long_xact.sql
+ cpp -P -traditional-cpp -DUSE_VERSION=$(USE_VERSION) $< | sed -e 's#@MODULE_FILENAME@#$(REGRESS_MODULE_FILENAME)#g;s#@POSTGIS_VERSION@#$(POSTGIS_VERSION)#g;s#@POSTGIS_SCRIPTS_VERSION@#$(SCRIPTS_VERSION)#g;s/@POSTGIS_BUILD_DATE@/$(POSTGIS_BUILD_DATE)/g' | grep -v '^#' > $@