aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-02-19 21:36:00 +0800
committerrakuco <rakuco@FreeBSD.org>2014-02-19 21:36:00 +0800
commitb30d5240487ba0c763ff1ccd48c92dfe3e144e48 (patch)
tree15223cdaef79337933f7f893c464245d782ec844 /databases
parent97a7bd25222e0b5d80a415739008bf0cad301a99 (diff)
downloadfreebsd-ports-graphics-b30d5240487ba0c763ff1ccd48c92dfe3e144e48.tar.gz
freebsd-ports-graphics-b30d5240487ba0c763ff1ccd48c92dfe3e144e48.tar.zst
freebsd-ports-graphics-b30d5240487ba0c763ff1ccd48c92dfe3e144e48.zip
Add upstream patch to fix the build with clang 3.4.
clang 3.4 is pickier and refuses to work when passed flags it does not understand, such as -fno-check-new in this case. PR: ports/186873
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi/Makefile1
-rw-r--r--databases/akonadi/files/patch-git_938e923122
2 files changed, 23 insertions, 0 deletions
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 78f331aad5b..8a7cd7540ce 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= akonadi
PORTVERSION= 1.11.0
+PORTREVISION= 1
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/${PORTNAME}/src
DIST_SUBDIR= KDE
diff --git a/databases/akonadi/files/patch-git_938e9231 b/databases/akonadi/files/patch-git_938e9231
new file mode 100644
index 00000000000..70ae21707e9
--- /dev/null
+++ b/databases/akonadi/files/patch-git_938e9231
@@ -0,0 +1,22 @@
+commit 938e923143364a2786a0b5bd3e303b1dcd82dfe3
+Author: Dan Vrátil <dvratil@redhat.com>
+Date: Sun Dec 22 19:25:17 2013 +0100
+
+ Remove -fno-check-new from CXX_FLAGS
+
+ This flag is not supported by Clang and generates a warning or build error
+ when using Clang. The overhead of non-null check should be minimal.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e18608a..f22921c 100644
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -241,7 +241,7 @@ if(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_C_COMPILER MATCHES "icc" OR (CMAKE_CXX_COMP
+
+ # more aggressive warnings and C++11 support
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -Wextra -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -Wnon-virtual-dtor -Wundef -Wcast-align -Wchar-subscripts -Wall -Wextra -Wpointer-arith -Wformat-security -fno-check-new -fno-common")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -Wnon-virtual-dtor -Wundef -Wcast-align -Wchar-subscripts -Wall -Wextra -Wpointer-arith -Wformat-security -fno-common")
+
+ # debugfull target
+ set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline" CACHE STRING "Flags used by the C++ compiler during debugfull builds." FORCE)